Run spfx web part

%3CLINGO-SUB%20id%3D%22lingo-sub-2883656%22%20slang%3D%22en-US%22%3ERun%20spfx%20web%20part%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2883656%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20new%20in%20sharepoint%20I%20tried%20to%20start%20a%20web%20part%20spfx%26nbsp%3B%20and%20I%20want%20to%20have%20a%20hello%20world%20for%20first%20job%3C%2FP%3E%3CP%3Ebut%20after%20I%20draged%20my%20solution%20%3CHELLOWORLD-WEBPART.SPPKG%3E%20in%20app%20catalog%20area.%20I%20can't%20use%20this%20app%20and%20I%20got%20this%20error%3A%3C%2FHELLOWORLD-WEBPART.SPPKG%3E%3C%2FP%3E%3CP%3ESorry%2C%20apps%20are%20turned%20off.%20If%20you%20know%20who%20runs%20the%20server%2C%20tell%20them%20to%20enable%20apps%3C%2FP%3E%3CP%3ECan%20anybody%20help%20me%20what%20is%20wrong%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2885546%22%20slang%3D%22en-US%22%3ERe%3A%20Run%20spfx%20web%20part%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2885546%22%20slang%3D%22en-US%22%3EIt%20sounds%20like%20you%20are%20using%20SharePoint%202019%3F%20The%20error%20could%20be%20several%20issues.%20This%20article%20walks%20through%20several%20possible%20solutions.%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.shortpoint.com%2Fsupport%2Fsolutions%2Farticles%2F1000273552-you-get-error-saying-sorry-apps-are-turned-off-if-you-know-who-runs-the-server-tell-them-to-enabl%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.shortpoint.com%2Fsupport%2Fsolutions%2Farticles%2F1000273552-you-get-error-saying-sorry-apps-are-turned-off-if-you-know-who-runs-the-server-tell-them-to-enabl%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20this%20helps%2C%20please%20consider%20marking%20this%20as%20the%20accepted%20answer.%20Good%20luck!%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi 

I am new in sharepoint I tried to start a web part spfx  and I want to have a hello world for first job

but after I draged my solution <helloworld-webpart.sppkg> in app catalog area. I can't use this app and I got this error:

Sorry, apps are turned off. If you know who runs the server, tell them to enable apps

Can anybody help me what is wrong?

4 Replies
It sounds like you are using SharePoint 2019? The error could be several issues. This article walks through several possible solutions.
https://support.shortpoint.com/support/solutions/articles/1000273552-you-get-error-saying-sorry-apps...

If this helps, please consider marking this as the accepted answer. Good luck!

@Don Kirkham 

Hi, 

Thanks for you reply, I saw this article befoe. I tried to follow the article
The article first subject was correct it was enabled.

The second theme of the first part was correct.

When I tried to paste the command in sharepoint2019shell, I got the following error, I didn't know what else to do if you can help me

spfx error-10-26-21.png


thanks a lot
Daryush

@Daryush1342 

Looks like the article put two commands together by mistake. Split the commands into the following:

 

$sa = New-SPSubscriptionSettingsServiceApplication -ApplicationPool 'SharePoint Web Services Default' -Name 'Subscriptions Settings Service Application' -DatabaseName 'Subscription'

 

New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $sa 

 

That should get you through the next step. Good Luck

@Don Kirkham 

Hi,

Thanks again for your reply. I tried your guide  unfortunately I got this error in both commands 

 

error spfx 2.png

I have a question is it posible  to use spfx in sharepoint 2019 on premise? because most tutorials I saw there were about sharepoint online?

 

Best Regards,

Daryush