React Script Editor Communications Site

Brass Contributor

I have deployed the SpFX React Script Editor to my App Catalog. In a Team site, I can see it in the web part drop down but not in a Communications Site. Is this normal behavior?

11 Replies

Hi @Chris_Mancini 

I have the same problem.

Did you found any solution???


I don’t believe I actually deployed it but I got it working.

@Chris_Mancini how??? only re-deploying the component????

@DaniFC If you have uploaded it to your App Catalag make sure it is Enabled by going to right clicking the item and choosing Properties from the menu. Check the Enabled box and click Save. It should then be available to add to your sites.

Yes, I deployed the solution, its appear in the appcatalog and it is enabled.

Then when i try to add into a moderpage the webpart, in some sites appear but in other(in this case in comunication sites) dont appear. But still work in modern pages from team site for example.

@DaniFC Did you follow all of the instructions per the "Minimal Path to Awesome" section on this page:


@DaniFC I have the same issue.


I was able to use the Modern Script Editor in Team Sites but not in Communication Sites.


In CS I am able to add the web part in the site contents but for some reason it does not show when I try to add it on a page.


Did you find a solution for this?



@Jose_Clua  You might want to check this out. I seem to remember that I had to run the Powershell mentioned for Modern sites as they are noscript sites by default.



Yes from central admin you can allow scripts for that kind of sites. Works for me ;)

@Chris_Mancini , it did the trick!

Previously I ran the powershell specifically for the Team Sites, where I was able to add the Modern Script Editor Web Part.

But then I had enabled client scripts in admin center and I thought that was a tenant wide configuration. 

So after reading your post I decided to run the Powershell for the Communication Site and... it worked.

Now I am able to add the web part in that site as well.


Thank you so much for your help!

@DaniFC for me allowing client scripts in the admin center was not enough.


I also had to run this powershell:


Set-SPOsite <SiteURL> -DenyAddAndCustomizePages 0