PnP - Site property bag items not indexed anymore by search


I apply a PnP template on an out of the box classic team site. Within this template I use the property bag element in my xml in order to add items to the property bag. Each property bag item has the attribute indexed="true" on it. The new property bag items are not picked up by the search crawler anymore. No crawled properties are created for the property bag items and so I am not able to map it to a managed property. In the past I used the same technique on an other template. When I use the same key for a property in that template in the other template, it is not picked up by search. The crawled property of this item is already in the index. When mapping it to a refinablestring managed property, no values come through. I waited for days now, nothing there. I tried re-indexing the site, etc. but no luck.

This morning I got a ticket from another client with the same issue. Same technique is used there.


Anyone with the same issue or does anybody know if something changed on this part?

@Vesa Juvonen: any ideas?

17 Replies

Created a premier call for this issue at Microsoft. Got the following answer back:


I just had a quick chat with our Product team.  The information I heard was not favorable at all.

As per the  conversation they said Search is not indexing site property bag anymore. The change have been introduced  recently.


So if you have any solutions using this technique, it won't work anymore!

Thank you for this important information! I guess it is valid for SharePoint Online? Or did I miss something in the update-notes for on Prem?

This just can't be true...I can't imagine they'd introduce a breaking change like this without further notice. This would impact so many customers...


But I have noticed a similar issue these days. In the end it turned out the issue only occures if you change permissons on the pages library or directly on the homepage of your site. In my case we had set read only permissions on the homepage so users could not modify the page.

Any chance this could be the same issue with your site?


After we changed that, everything worked perfectly again. Strange thing only happend on some sites, but after the change it never happened again so far.

I still think it is a bug, but I have learned, working around issues is a lot easier and faster than waiting for MS to fix them...


as addition attached a piece of mail from MS

AFAIK the pnp provisioning engine does set the properties on SPWeb. There is no propertybag on sitecollection level....


Look at the issue I described above. Are you changing permissions for the sitepages library or the homepage? This might solve your problem...



Thank your for your information. I indeed change the permissions on the homepage. I will test if this will solve the issue. Though, I am still bussy with Premier support and they are stating it is removed.

Okay, I am pretty sure that this is your issue then. Just reset the permissions back to inherit and reindex your site via Site Settings>Search and Offline Availability>Reindex Site and your property bag items will get crawled within a few minutes.

If you don't start the reindex, it will take much longer....

If you have opened a premiere support ticket already, tell them the cause of the issue so they can fix it so others don't run into this...Because I think this is clearly a bug on MS side...



No luck yet. I reset the permissions of the page and did a re-index of the site. Waited a few hours, but nothing yet. I will check tomorrow again and let you know.



Seems like it is working indeed when inheriting the permissions on the home page again. Re-index took a while... I also tested it at another client with the same issue and also works there.


Microsoft is looking at our tenant now. Strange thing is I now retrieve some sites with broken permissions too with filled property from property bag. We are going to let this further investigated by Microsoft. Hopefully a fix will solve this...

That is exactly what I am seeing. Some sites do indeed work fine, even with broken permissions. It is only in about 30-40% that search breaks. But once it is broken for that site, the only way back is to reset the permissions.

Even changing the title for this site will not show up within search. So it is not just propertybags, it is the full site that is broken in this case.


I could reproduce this on more than 5 tenants and it used to be working just fine.

Hi Robert, any update from MS on this? Were you ever able to get this working reliably? 


I'm creating a template from a modern team site, enabling script, updating the property bag (on the web), and then disabling script. I can see my property bag value, and I can see that it's been added to the vti_indexedpropertykeys, but it never shows up as a crawled property.



Hi Cameron,


I have been though long conversations with MS premier support. I got no clear answer, but as stated before when inheriting permissions for the start page the property bag items were picked up by search. At some test sites at our client at some point it was nog working and the other day it was working again. So support stated it was not reproducible anymore and therefore the case was closed. My client didn't have problems anymore after that.


I have to state that this was for classic sites. I am not really sure if Search will pick property bag items up on modern sites at all. By default scripts are disabled, so I could imagine that modern sites are skipped on this part. If you have anymore information if modern sites do support this, please let me know!

Thanks Robert, I appreciate the response. I've got the question posted up to a couple other boards. I'll come back update this thread when I find out more. 


I've got my suspicions that it's somehow related to the modern site template as well. We haven't changed any of the permissions on the start page in our case so I'm not sure where to go from here.

Thank You! All of you for your feedback and observations !

I am considering to use the web level Indexed property bag option to implement a solution throughout my SPO tenant. However, based on all your observations it looks like indexed property bags are recently causing issues sporadically.
Is this issue only for modern team sites or classic site as well ? 

Please do share in case any latest update from MS PG on this.


@Cameron Sibbald @Robert Schouten

The issue was on classic sites. I have used indexed property bags a lot, not causing any troubles. As stated above in the older posts, there were some issues when the welcome page got broken permissions on it. Next to this issue, I have never had any other issue. I haven't used this technique on Modern sites yet. So if you have anything to share?

I was seeing the issue on modern sites and was unable to get it working at all (not even sporadically). We ended up creating a custom schema for the O365 groups and stored our metadata there, where we were able to query the property using the Graph API.

Hi everyone,


I currently have an issue where a web property bag key does not get indexed, even after several days.

I've added the property bag entry to a subweb of a Project Web App site. This subweb has unique permissions assigned and is a classic site. The welcome page of the subweb does not have unique permissions assigned.

It also seems that regular content gets crawled normaly. Does anyone have some thoughts on this?