On InfoPath form submission an erroneous Access Denied message shows

Brass Contributor



  • Office 365 (SharePoint Online)
  • InfoPath 2013 with data connection to Form lib and incoming data connection to a list. InfoPath submission button submits changes using a submit data connection. 
  • SharePoint Designer 2013
  • Tested on Windows 10 or Windows 7
  • Tested on Edge/Chrome/Internet Explorer/Firefox
  • Permissions are granted by a SharePoint Designer 2013 workflow, particularly by a 2010 add/remove permissions function within the 2010 wf which has worked for months without problem until a few months ago (WITH NO CHANGE TO IT!)

The problem:

On 2 or 3 InfoPath and SharePoint Designer based form and workflows, situated on SharePoint Form Libraries an Access Denied message appears when a form is submitted. The strange thing is that the form is submitted successfully with no problems. Another strange characteristic is that the user gets the Access Denied message the first time they submit, but a second time it doesn't appear. They can submit without encountering the message. Hope this gives a clue.


The end user (the one who receives the email to action the form) will receive a SPD generated email and will click on an encoded absolute URL which takes them directly to the form. They then change the form and click Save. The whole thing is a glorified Approval process.
Once the form is saved with the changes it then should show 'This form has been closed' or something along those lines, yet it shows Access Denied.


I have spent several hours on the phone to a Microsoft support technician who I have been able to recreate the issue to. He spent a long time trying to figure out what is wrong, circling back to permissions settings but has decided that it is not a permissions based issue. I also agree because this particular system we tested it on worked without problem for months until a few months ago when this problem just started out of nowhere. 


We have ITS managed and unmanaged PC's here at our organisation. Managed means there are security policies pushed down to client PC's where most are still Win7 but increasingly Win10. We tested on both Managed and Unmanaged Win7 and Win10 with all browsers and it occurs on all so it potentially eliminates security policies. 


The Access Denied message is attached. Please remember that it's not a permissions thing - we've checked Limited Access permission groups, checked if the permissions are being incorrectly set by the workflow, (they are not). 


Anyone help?



2 Replies

Presume you have used the developer tools in your browser to see if it shows what call is failing when you get the access denied error?

Hello Peter,


Yes but that reveals little to me. Can I send them directly to you? I will black out any sensitive data.