Not able to read one of the column created in sub site with read permissions and using REST query

%3CLINGO-SUB%20id%3D%22lingo-sub-766665%22%20slang%3D%22en-US%22%3ENot%20able%20to%20read%20one%20of%20the%20column%20created%20in%20sub%20site%20with%20read%20permissions%20and%20using%20REST%20query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-766665%22%20slang%3D%22en-US%22%3E%3CP%3E-%20User%20have%20%3CSTRONG%3Eread%20access%20to%20the%20parent%20site%20and%20the%20sub%20site%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E-%20I%20am%20using%20%3CSTRONG%3EREST%20Call%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E-%20Not%20able%20to%20query%20a%20field%2Fcolumn%20in%20the%20site%20pages%20list%20from%20sub%20site%3C%2FP%3E%3CP%3E-%20eg%3A%20%3CSTRONG%3E%3CSITE%3E%2F%3CSUBSITE%3E%2F_api%2Fweb%2Flists%2Fgetbytitle('Site%2520Pages')%2Fitems%3F%24select%3DID%2CLinkFilename%26amp%3B%24filter%3DisITAnnouncement%20eq%200%3C%2FSUBSITE%3E%3C%2FSITE%3E%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E-%20Not%20able%20to%20read%20using%20the%20above%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20or%20advice%20where%20I%20am%20going%20wrong.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-766665%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAPIs%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-806267%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20able%20to%20read%20one%20of%20the%20column%20created%20in%20sub%20site%20with%20read%20permissions%20and%20using%20REST%20quer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-806267%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F244492%22%20target%3D%22_blank%22%3E%40TarundeepSinghTheta%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20kind%20of%20error%20are%20you%20getting%3F%20Are%20you%20able%20to%20query%20other%20fields%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

- User have read access to the parent site and the sub site.

- I am using REST Call

- Not able to query a field/column in the site pages list from sub site

- eg: <Site>/<Subsite>/_api/web/lists/getbytitle('Site%20Pages')/items?$select=ID,LinkFilename&$filter=isITAnnouncement eq 0

- Not able to read using the above

 

Any help or advice where I am going wrong.

1 Reply
Highlighted

@TarundeepSinghTheta 

 

What kind of error are you getting? Are you able to query other fields?