New-PnPSite fails with "App-Only is currently not supported"

%3CLINGO-SUB%20id%3D%22lingo-sub-138719%22%20slang%3D%22en-US%22%3ENew-PnPSite%20fails%20with%20%22App-Only%20is%20currently%20not%20supported%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-138719%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20script%20with%20the%20new-pnpsite%20cmdlet%20that%20has%20been%20working%2C%20I%20just%20ran%20it%20again%20I'm%20getting%20an%20error%20that%26nbsp%3BApp-Only%20is%20currently%20not%20supported.%26nbsp%3B%20Does%20anyone%20know%20what%20would%20cause%20this%20or%20how%20to%20fix%20it%3F%3C%2FP%3E%0A%3CP%3ETIA%3C%2FP%3E%0A%3CP%3EDean%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F122%22%20target%3D%22_blank%22%3E%40Erwin%20van%20Hunen%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIt%20turns%20out%20that%20this%20problem%20occurs%20in%26nbsp%3B%3CSPAN%20class%3D%22css-truncate-target%22%3E%3CA%20class%3D%22css-truncate%22%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%2Ftree%2F2.21.1712.2%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3E2.21.1712.2%3C%2FA%3E%26nbsp%3Bwhen%20i%20roll%20back%20to%26nbsp%3B%3CA%20class%3D%22css-truncate%22%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-PowerShell%2Ftree%2F2.20.1711.0%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3E2.20.1711.0%3C%2FA%3E%26nbsp%3Bmy%20script%20works%20fine%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-138719%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPnP%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-144447%22%20slang%3D%22en-US%22%3ERe%3A%20New-PnPSite%20fails%20with%20%22App-Only%20is%20currently%20not%20supported%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-144447%22%20slang%3D%22en-US%22%3EAlso%20fails%20in%20the%20latest%20version%3A%3CBR%20%2F%3ESharePointPnPPowerShellOnline%202.22.1801.0%3C%2FLINGO-BODY%3E
Respected Contributor

I have a script with the new-pnpsite cmdlet that has been working, I just ran it again I'm getting an error that App-Only is currently not supported.  Does anyone know what would cause this or how to fix it?

TIA

Dean

@Erwin van Hunen

 

It turns out that this problem occurs in 2.21.1712.2 when i roll back to 2.20.1711.0 my script works fine

1 Reply
Also fails in the latest version:
SharePointPnPPowerShellOnline 2.22.1801.0