SOLVED

Modern pages provisioning without comments

Highlighted
Microsoft

PnP PowerShell - https://github.com/OfficeDev/PnP-PowerShell

 

The modern page should provision with page Comments.

The page provisioned without Comments and Comments are not enabled after provisioning.

Steps to Reproduce

Create page and add comments
use: 

Get-PnPProvisioningTemplate -Out Path/File.pnp -Handlers Pages, PageContent

Applying template with following cmdlet

Apply-PnPProvisioningTemplate -Path Path/File.pnp

-xml Template below:

<?xml version="1.0"?> <pnp:Provisioning xmlns:pnp="http://schemas.dev.office.com/PnP/2017/05/ProvisioningSchema"> <pnp:Preferences Generator="OfficeDevPnP.Core, Version=2.22.1801.0, Culture=neutral, PublicKeyToken=5e633289e95c321a" /> <pnp:Templates ID="CONTAINER-TEMPLATE-2DDD25B9739B476DB6E44DC517C1FF2C"> <pnp:ProvisioningTemplate ID="TEMPLATE-2DDD25B9739B476DB6E44DC517C1FF2C" Version="1" BaseSiteTemplate="SITEPAGEPUBLISHING#0" Scope="RootSite"> <pnp:WebSettings NoCrawl="false" WelcomePage="SitePages/MP2.aspx" /> <pnp:ClientSidePages> <pnp:ClientSidePage PageName="MP2.aspx" PromoteAsNewsArticle="false" Overwrite="false"> <pnp:Sections> <pnp:Section Order="1" Type="TwoColumnLeft"> <pnp:Controls> <pnp:CanvasControl WebPartType="Text" ControlId="7aca70c6-02bc-4b46-a27e-093e34a7a4dc" Order="1" Column="1"> <pnp:CanvasControlProperties> <pnp:CanvasControlProperty Key="Text" Value="&lt;p&gt;This is a paragraph of text in a Text web part. It's a good place to introduce yourself, describe your project or team, or add any information you need on your page. Just click within this text and replace it with your own.&lt;/p&gt;&#xA;&#xA;&lt;p&gt;You can use the formatting bar above to&lt;/p&gt;&#xA;&#xA;&lt;ul&gt;&#xA; &lt;li&gt;change styles&lt;/li&gt;&#xA; &lt;li&gt;add bullets&lt;/li&gt;&#xA; &lt;li&gt;align text&lt;/li&gt;&#xA; &lt;li&gt;add links&lt;/li&gt;&#xA;&lt;/ul&gt;&#xA;&#xA;&lt;p&gt;You can delete the whole Text web part by clicking the Delete web part button on the left, or move it by clicking the Move web part button on the left.&lt;/p&gt;&#xA;" /> </pnp:CanvasControlProperties> </pnp:CanvasControl> </pnp:Controls> </pnp:Section> </pnp:Sections> </pnp:ClientSidePage> </pnp:ClientSidePages> </pnp:ProvisioningTemplate> </pnp:Templates> </pnp:Provisioning>
2 Replies
Highlighted
Best Response
Solution

I'd suggest you to report this issue in the Issues list of the appropriate GitHub repository. From there there's a greater chance someone notices the issue and picks it up to resolve.

Highlighted
Did that too. Thanks for the response.