Modern Lists no longer load Classic forms if Content Editor is present

%3CLINGO-SUB%20id%3D%22lingo-sub-1558286%22%20slang%3D%22en-US%22%3EModern%20Lists%20no%20longer%20load%20Classic%20forms%20if%20Content%20Editor%20is%20present%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1558286%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENoticed%20today%20that%20on%20a%20couple%20lists%20where%20we've%20added%20a%20content%20editor%20to%20the%20underlying%20newform.aspx%2C%20to%20run%20our%20own%20JS%20etc%2C%20have%20stopped%20automatically%20loading%20the%20classic%20forms.%20It%20used%20to%20be%20that%20if%20SharePoint%20detected%20you%20were%20using%20something%20that%20didn't%20work%20on%20the%20modern%20forms%2C%20it%20would%20load%20classic%20(and%20this%20does%20still%20happen%20on%20some%20other%20sites%2Ftenants%20I've%20tested).%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EAre%20there%20any%20official%20updates%20on%20this%20behaviour%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1709066%22%20slang%3D%22en-US%22%3ERe%3A%20Modern%20Lists%20no%20longer%20load%20Classic%20forms%20if%20Content%20Editor%20is%20present%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1709066%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F119118%22%20target%3D%22_blank%22%3E%40Peter-Ross%20Cuthbert%3C%2FA%3E%2C%26nbsp%3BI've%20noticed%20this%20behavior%2C%20too%2C%20just%20today.%20We%20have%20a%20jQuery%20script%20in%20a%20content%20editor%20web%20part%20on%20an%20older%20classic%20site%2C%20so%20that%20certain%20fields%20are%20hidden%20or%20read-only%20unless%20you%20are%20in%20a%20particular%20SharePoint%20group%20(for%20approvals).%20Now%2C%20when%20editing%20items%2C%20only%20the%20details%20pane%20will%20open%2C%20where%20all%20visible%20fields%20are%20editable.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

Noticed today that on a couple lists where we've added a content editor to the underlying newform.aspx, to run our own JS etc, have stopped automatically loading the classic forms. It used to be that if SharePoint detected you were using something that didn't work on the modern forms, it would load classic (and this does still happen on some other sites/tenants I've tested). 

Are there any official updates on this behaviour? 

1 Reply

@Peter-Ross Cuthbert, I've noticed this behavior, too, just today. We have a jQuery script in a content editor web part on an older classic site, so that certain fields are hidden or read-only unless you are in a particular SharePoint group (for approvals). Now, when editing items, only the details pane will open, where all visible fields are editable.