SOLVED

Issues creating a site collection from provisioning template created from 0365 starter intranet PnP

%3CLINGO-SUB%20id%3D%22lingo-sub-40628%22%20slang%3D%22en-US%22%3EIssues%20creating%20a%20site%20collection%20from%20provisioning%20template%20created%20from%200365%20starter%20intranet%20PnP%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-40628%22%20slang%3D%22en-US%22%3E%3CP%3EOk%20the%20scenario%20is%20that%20i%20used%20%3CSPAN%3EPowerShell%20Scripting%20(thanks%20to%20the%20efforts%20of%20Erwin%3C%2FSPAN%3E%3CSPAN%3E!)%20to%20%26nbsp%3Bcreate%20a%20provisioning%20template%20of%20the%200365-starter-intranet%20available%20in%20the%20pnp%20samples.%20When%20I%20upload%20the%20xml%20%26nbsp%3Btemplate%20and%20use%20the%20schedule%20job%20to%20create%20a%20new%20site%20based%20on%20this%20template%20i%20get%20the%20following%20error%20%22The%20web%20template%20BLANKINTERNET%230%20is%20not%20available%20for%20sites%20on%20this%20tenant.%22%20Any%20suggestions%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41356%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20creating%20a%20site%20collection%20from%20provisioning%20template%20created%20from%200365%20starter%20intranet%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41356%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20that%20pointed%20me%20in%20the%20right%20direction.%20However%20now%20i%20am%20getting%20the%20infamous%20%22%3CSTRONG%3EMicrosoft.SharePoint.Client.ServerException%3A%20Operation%20is%20not%20valid%20due%20to%20the%20current%20state%20of%20the%20object%3C%2FSTRONG%3E%3CSPAN%3E.%3C%2FSPAN%3E%22%20Almost%20every%20time%20i%20create%20a%20site%20collection%20now%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41331%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20creating%20a%20site%20collection%20from%20provisioning%20template%20created%20from%200365%20starter%20intranet%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41331%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20not%20familiar%20with%20the%20solution%20you%20used%2C%20but%20I%20do%20know%20the%20site%20definition%20BLANKINTERNET%230%20(Publishing%20Site)%20is%20designed%20only%20to%20be%20used%20for%20creating%20subsites%2C%20not%20site%20collections.%20Does%20your%20XML%20template%20specify%20BLANKINTERNET%230%20somewhere%20within%20its%20contents%3F%20If%20so%20you%20could%20maybe%20try%20to%20replace%20it%20with%20BLANKINTERNETCONTAINER%230%20(Publishing%20Portal%20-%20another%20site%20definition)%20and%20see%20what%20happens.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-40636%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20creating%20a%20site%20collection%20from%20provisioning%20template%20created%20from%200365%20starter%20intranet%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-40636%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EHi%20thanks%20for%20the%20reply.%20%26nbsp%3BManually%20I%20see%20only%20%22Publishing%20Portal%22%20and%20%22Enterprise%20Wiki%22%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-40634%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20creating%20a%20site%20collection%20from%20provisioning%20template%20created%20from%200365%20starter%20intranet%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-40634%22%20slang%3D%22en-US%22%3EWhen%20you%20manually%20create%20a%20site%20collection%20is%20publishing%20site%20available%3F%3C%2FLINGO-BODY%3E
Contributor

Ok the scenario is that i used PowerShell Scripting (thanks to the efforts of Erwin!) to  create a provisioning template of the 0365-starter-intranet available in the pnp samples. When I upload the xml  template and use the schedule job to create a new site based on this template i get the following error "The web template BLANKINTERNET#0 is not available for sites on this tenant." Any suggestions?

4 Replies
When you manually create a site collection is publishing site available?

Hi thanks for the reply.  Manually I see only "Publishing Portal" and "Enterprise Wiki" 

best response confirmed by Debayo Graham (Contributor)
Solution

I'm not familiar with the solution you used, but I do know the site definition BLANKINTERNET#0 (Publishing Site) is designed only to be used for creating subsites, not site collections. Does your XML template specify BLANKINTERNET#0 somewhere within its contents? If so you could maybe try to replace it with BLANKINTERNETCONTAINER#0 (Publishing Portal - another site definition) and see what happens.

 

 

Thanks that pointed me in the right direction. However now i am getting the infamous "Microsoft.SharePoint.Client.ServerException: Operation is not valid due to the current state of the object." Almost every time i create a site collection now