Issue with generating new client secret for Azure hosted sharepoint App

Copper Contributor

Hello, We are having issues on updating an expired client secret for a Azure hosted sharepoint add on.


We have followed below guide to renew the clientsecret and have done so in the past using the same method : But now we get an error saying "Invalid issuer or signature."


Another possible solution we have tried was using this page to create the new service principle (as other online sources reported this might solve our issue). But the page always gives us a "Oops something went wrong message" : "https://OUR SHARPOINT SITE/_layouts/15/AppRegNew.aspx" 


We have also used the Remove-MsolServicePrincipalCredential command, and removed all the keys for this clientID and generated a new on afterwards, with no success either.


The last suggestion I found online was to add <add key="HostedAppHostNameOverride" value="" /> to our web.config file. But this also does not help.


I had created a ticket with Microsoft and they advised me to create a post here.


Does anybody have any ideas we could try?


Kind Regards




2 Replies

I've seen the registrations take upwards of 24 hours from the creation. So when you generate your new secret, and update your web.config for application, it will take 24 hours before it can be used. 

Hi, Thank you for the tip. But we allready waited 48h between friday and monday, and still no success.

On monday we deleted everything and tried again with "assistance" from the O365 support team, and now 48h later it still does not work...