Issue: Required column does not have an asterisk(*) next to it on the New and Edit forms

Copper Contributor


 I created an Equipment Log list on Sharepoint Online with five  columns:

  • Last Name
  • First Name
  • Start Date
  • End Date
  • Item (renamed from the default Title. This column is  required.)

I added couple of records. I then modified the table and set these 3 columns to required as well

  • Last Name
  • First Name
  • Start Date

When I then tried to add a New record or update an existing record, those 3 required columns did not have an asterisk(*) next to them on the New/Edit forms and when I clicked the Save button, I did not get the validation error message

              "An entry is required or has an invalid value. Please correct and try again."

for those 3 columns.


I think this is a bug. Has anyone else encountered this?


Thank you.



1 Reply

@Burak_Gunay I followed the same steps as you said but I am not getting the same error.


Let me know if yo don't see the below screen you can see the columns where required data is misisngis automatically getting highlighted.


An i also get the the required asterisk mark in classic and new form both.