SOLVED

Invoke-PnPSiteTemplate : The parent content type specified by content type identifier

Copper Contributor

Hello All,

 

I am working on PnP site provisioning in SharePoint online.

I am able to create template xml file using the below command:

Get-PnPSiteTemplate -Out "PnP-Provisioning-File.xml" -PersistBrandingFiles -IncludeAllPages -IncludeSiteGroups -Force

 

But when applying the template to target site, it is throwing the below error:

Invoke-PnPSiteTemplate : The parent content type specified by content type identifier 
0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF39004C1F8B46085B4D22B1CDC3DE08CFFB9C does not exist.

 

When I have done troubleshooting then got to know that "Enterprise Wiki Page" content type is missing.

 

My question is why Get-PnPSiteTemplate command is not including "Enterprise Wiki Page" content type and how to resolve it?

 

 

2 Replies
best response confirmed by RamBhajan (Copper Contributor)
Solution

Hi @RamBhajan ,

 

i think that 0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF39004C1F8B46085B4D22B1CDC3DE08CFFB9C is the enterprise wiki page content type.

That requires the "
SharePoint Server Publishing Infrastructure" Feature (a392da98-270b-4e85-9769-04c0fde267aa) to be activated on site collection level.

I just tried that and was not able to activate that feature on a communication site (Got an error page), but it worked on a team site. I am pretty sure, that that still worked two weeks ago.
Perhaps MS is currently doing some changes with that feature.

Did you use a communication site or a team site?
Try activating that feature "SharePoint Server Publishing Infrastructure" manually and check if your provisioning template contains a feature activation of "a392da98-270b-4e85-9769-04c0fde267aa"

Best Regards,
Sven

@SvenSieverding- It worked...:) Thank you so much.

 

1 best response

Accepted Solutions
best response confirmed by RamBhajan (Copper Contributor)
Solution

Hi @RamBhajan ,

 

i think that 0x010100C568DB52D9D0A14D9B2FDCC96666E9F2007948130EC3DB064584E219954237AF39004C1F8B46085B4D22B1CDC3DE08CFFB9C is the enterprise wiki page content type.

That requires the "
SharePoint Server Publishing Infrastructure" Feature (a392da98-270b-4e85-9769-04c0fde267aa) to be activated on site collection level.

I just tried that and was not able to activate that feature on a communication site (Got an error page), but it worked on a team site. I am pretty sure, that that still worked two weeks ago.
Perhaps MS is currently doing some changes with that feature.

Did you use a communication site or a team site?
Try activating that feature "SharePoint Server Publishing Infrastructure" manually and check if your provisioning template contains a feature activation of "a392da98-270b-4e85-9769-04c0fde267aa"

Best Regards,
Sven

View solution in original post