Installing new SharePoint Provider Hosted Add-ins to new tenants - "The operation took too long"



Has something changed in SharePoint Online within the last week with SharePoint add-ins? Since around Thursday last week, all SharePoint provider hosted add-ins fail to install with an error "The operation took too long":


If the add-in has previously been installed on the tenant then you want to add the add-in to a new site collection on the same tenant, that works fine. It doesn't work if the add-in is going into a tenant for the first time.

Has anyone else seen this issue?
Many thanks

30 Replies

@Paul Mather I have the same issue, tried different tenants and different computers. Its completely stopped our development flow. 

I have the same issue in my tenant. Raised MS support ticket as well waiting for response.

That's great you've raised it @Padmanaban_Jayaraman, all we can do it all raise support tickets to get this issue noticed. Anyone else who has this issue - please open a support ticket as soon as you can. 

We have the same issue. Started around 4pm CST 6/1/22. It works when we test on a different tenant, so it seems to be tenant specific. We've opened a MS ticket and they're digging into it.

Hello @ChrisbChicken ,

Any update from Microsoft for your issue?

Hello @Padmanaban_Jayaraman ,

Any update from Microsoft on your support issue?

I seem to be having the same issue. I'm trying to deploy an add-in to various dev sites and they all give this error. I tried fully deleting the registered add-in from older dev sites that already had a version working, then tried to deploy it via Visual Studio. This also gave the same error.

Has anyone been able to fix this?

We are having the same issue. The issue also occurs when trying to deploy an Add-In from Visual Studio. It hangs in the installation step of the Add-In in SharePoint. Right now there's no way to continue to debug our Apps, including very critical applications for DAX 100 companies..

@Sid_Clemens have you opened a Microsoft support ticket? If not, please do!

Yes, i opened a ticket. Waiting for a reply
Same issue here for a couple of tenants, one of them just created a few days ago and the other one created a few weeks ago.
Error "The operation took too long.", no matter if I unregister and register the add-in again, or recreate the site collection where I'm trying to activate it.
The same add-in is working perfectly in many other tenants and can be add it to them, too.
Raised a ticket a few hour ago and I have already been contacted, but got no diagnostic so far.

Thanks @Enric Carrión ,

This is the same issue we are seeing. Our SharePoint client IDs and secrets are created via the Microsoft Seller Dashboard, is this the same for you? 

My case has been open with Microsoft since 30th May and still no progress. 

Hey @Paul Mather, no, we generate a random dynamic secret during the installation of our add-in. And client ID is always the same. The add-in is working perfectly in other tenants and it hasn't been modified at all since long ago. Let's see if we get some answers...

I'm having this same issue on two tenants. The only message we get is "The operation took too long". One of them was actually installed fine just last week and today it failed during the reinstall of the add-in. Please Microsoft we need a solution to this.

Hi @Xavi Reig ,

Have you opened a support ticket with Microsoft? If not, please do so to get the visibility this issue needs within Microsoft. 

hey @Paul Mather, yeah I opened two separate tickets and I actually got a response already in one of them: "After consulting with my back end team, it appears this feature has been temporarily removed while we make improvements to the interface. Not to worry though, it will be returning in the next security patch."


I've asked for an ETA.