How to extract / export document library templates and add to my pnp-provisioning template?

%3CLINGO-SUB%20id%3D%22lingo-sub-312982%22%20slang%3D%22en-US%22%3EHow%20to%20extract%20%2F%20export%20document%20library%20templates%20and%20add%20to%20my%20pnp-provisioning%20template%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-312982%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20need%20to%20export%20doc%20library%20templates%20and%20add%20them%20to%20my%20pnp-provisioning%20template%20to%20be%20abble%20to%20apply%20it%20to%20other%20webs.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20523px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F65734iEB5E45E274E5AE74%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22query1_pnp.png%22%20title%3D%22query1_pnp.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-319251%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20extract%20%2F%20export%20document%20library%20templates%20and%20add%20to%20my%20pnp-provisioning%20template%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-319251%22%20slang%3D%22en-US%22%3E%3CP%3EOk%2C%20i%26nbsp%3Bgot%20a%20little%20bit%20farher%2C%20now%20I%20have%20exported%20pnp%20template%20and%20I%20could%20see%20links%20to%20the%20document%20library%20tamplates%20in%20the%20file%20(in%20my%20case%20xml%20file%20format).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBUT%2C%20when%20I%20apply%20the%20template%20to%20a%20new%20site%20collection%2C%20after%20clicking%20on%20a%20new%20item%20in%20any%20document%20library%20with%20the%26nbsp%3Bdocument%20library%20template%2C%20it%20just%20open%20an%20empty%20page%2C%20so%20that%20new%20document%20based%20on%20a%20template%20isn't%20loaded%2C%20but%20on%20the%20original%20site%20from%20what%20is%20a%20template%20exported%20it%20works%20just%20fine%20%3A(%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESnippet%20of%20lines%20with%20links%20to%20document%20library%20templates%20in%20the%26nbsp%3Bxml%20template%26nbsp%3Bcould%20be%20seen%20on%20the%20attached%20screenshot...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20help%20me%26nbsp%3Bto%20find%20out%26nbsp%3Bwhere%20in%20the%20code%20is%20the%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EJosef%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-313813%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20extract%20%2F%20export%20document%20library%20templates%20and%20add%20to%20my%20pnp-provisioning%20template%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-313813%22%20slang%3D%22en-US%22%3E%3CP%3EOpen%20the%20site%20in%20sharepoint%20designer%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ego%20to%20all%20files%20-%26gt%3B%26nbsp%3BThe%20library%20with%20templates%20-%26gt%3B%20the%20files%20should%20be%20there%20or%20in%20forms%20-%26gt%3B%20content%20type%20name%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20that%20helps%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

I need to export doc library templates and add them to my pnp-provisioning template to be abble to apply it to other webs.

 

query1_pnp.png

2 Replies

Open the site in sharepoint designer 

 

go to all files -> The library with templates -> the files should be there or in forms -> content type name

 

Hope that helps

Ok, i got a little bit farher, now I have exported pnp template and I could see links to the document library tamplates in the file (in my case xml file format).

 

BUT, when I apply the template to a new site collection, after clicking on a new item in any document library with the document library template, it just open an empty page, so that new document based on a template isn't loaded, but on the original site from what is a template exported it works just fine :(

 

Snippet of lines with links to document library templates in the xml template could be seen on the attached screenshot...

 

Could you help me to find out where in the code is the issue?

 

Regards,

Josef