HELP, Cannot deploy upgrade to spfx application

Frequent Contributor

Hi,

I am trying to deploy an update to an SPFX Webpart Application. The app has been in production for months (it uses spfx 1.0.0) and I have been deploying updates regularly , without issues , until today.

 

The update worked fin in the workbench. The only change I made was to change an alert to a console.log. I update the version number , deployed to my app catalog and cdn. Updated  the app in the Site content of the web that previously had the solution.

 

 

 

Now when I go to the page that has the webpart, the webpart is not loading properly.  If I look at the console output I see:

 

 

 

 

 

 

 

 

 

 

Capture.PNGif I follow the link in the error, the page tells me "Element type is invalid: expected a string (for built-in components) or a class/function (for composite components) but got: object. Check the render method of `t`"

 

Any Idea what's happened? This was working fine a couple of weeks ago?

 

1 Reply
Turns out that react-select has started having issues causing my page not to render. I removed react-select and started using fabric ComboBox. (had to upgrade to spfx 1.3.4 and fabric 4.21.2) .Now it works fine