For News Web Part - Thumbanail is not showing

Brass Contributor

From Today, For News Web Part - Thumbanail is not showing . Inside Page, the image shows.

Thumbnail shows the below image. What could be the reason ?


11 Replies



We are seeing the same issue in several tenants. It seems that issue occurs only on rootsite with News webpart. When you open news itself, then picture is displayed correctly.


When looking at the console, I see following:


Given error message cannot resolve:



We reported an issue to MS also. Hoping it will get fixed soon...




The Culprit  is Power Apps. I tried to customize a list form using Power App. When I deleted from the list, the news web part started working properly.

Not in my case. I haven't done any changes using Powerapps and the news thumbnails are still missing.
Can you clarify if you tried to customize SitePages library with powerapps or some other list?



I tried to customize only the custom list. No changes made in the Site Page Library. But it effected  the Site Pages Home Page and inside pages showing the  news web part thumbnails.



Today I just installed and Configured ShortPoint  App. After that, again the same issue happened in the Root Site Collection. But  News Web Part thumbnail works in other site collections. ?


Is it anything related to App Catalog Site ? Please advise.



@Sajith G H 

Same in our environment.

2020-01-22 11_29_18-Intranet - Home.png



After uninstalling the App from Site (Different Site Collection) and App Catalog Site, it took almost 2 hours to fix the thumbnail images in the News Web Parts in the Root Site Collection.


How can we fix this ? This issue will come if we add any App in the Catalog Site again.


I had this issue for about half a day. I didn't change anything and it started displaying news thumbnails again. I suppose MS had fixed this issue....


I have not been able to make any edits or change colors in my news web parts anymore@ShareCloud 

@Sajith G H 


similar/same issues with modern News web part --

  • Thumbnail image will not show if the News web part settings is "Selected site", but post thumbnail will show if News web part is "This site only". Is this a Hub site issue?
  • Some posts thumbnail will show in News web part roll-up, others won't, it's about 50/50. All images are JPG and data-sp-originalimgsrc is /_api/v2.1/
  • Posts that are not displaying thumbnails, are instead, displaying this placement image:
  • Site permissions are the same for Parent Hub site and associated Hub sites.

Anyone able to get more clarity on this? TIA.

Please excuse me, I realized after posting this, that I have used a news web part but I needed a Hero Web part @Yu Chen It has been solved.