SOLVED

Environment for SPFX Which version

%3CLINGO-SUB%20id%3D%22lingo-sub-2900585%22%20slang%3D%22en-US%22%3EEnvironment%20for%20SPFX%20Which%20version%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2900585%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20wanted%20to%20create%20web%20part%20client-side%20SPFX%20for%20sharaepoint%202019%20on-promise.%3C%2FP%3E%3CP%3ECould%20you%20Pls.%20guide%20me%20which%20version%20node%20and%20which%20spfx%20which%20gulp%20version%20and%20which%20yo%20version%26nbsp%3B%3C%2FP%3E%3CP%3EI%20should%20install%20to%20be%20able%20my%20web%20part%20can%20be%20deployed%26nbsp%3B%20on%20sharepoint%202019%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20help%3C%2FP%3E%3CP%3EDaryush%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2940963%22%20slang%3D%22en-US%22%3ERe%3A%20Environment%20for%20SPFX%20Which%20version%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2940963%22%20slang%3D%22en-US%22%3EYou%20can%20find%20this%20outlined%20in%20the%20docs%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fsharepoint-2019-support%23nodejs-gulp--yeoman-versions%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fsharepoint-2019-support%23nodejs-gulp--yeoman-versions%3C%2FA%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi,

I wanted to create web part client-side SPFX for sharaepoint 2019 on-promise.

Could you Pls. guide me which version node and which spfx which gulp version and which yo version 

I should install to be able my web part can be deployed  on sharepoint 2019

 

Thanks for your help

Daryush

1 Reply
best response confirmed by Beau Cameron (MVP)