Custom profile property doesn't return Search results

%3CLINGO-SUB%20id%3D%22lingo-sub-674717%22%20slang%3D%22en-US%22%3ECustom%20profile%20property%20doesn't%20return%20Search%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-674717%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%20I%20have%20a%20custom%20user%20profile%20property%20called%20%22TellerNumber.%22%20I%20have%20crawled%20and%20set%20it%20up%20as%20a%20managed%20property%20(and%20full%20crawled%20again).%20But%20when%20my%20search%20query%20targets%20the%20values%20in%20this%20property%2C%20I%20only%20get%20results%20if%20I%20explicitly%20tell%20Search%20to%20target%20that%20property%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EWorks%3C%2FSTRONG%3E%3A%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20732px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F117342iA943B1212CA822C0%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22works.png%22%20title%3D%22works.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EDoesn't%20work%3A%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20716px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F117343i55B99085823ECD28%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22doesn't%20work.png%22%20title%3D%22doesn't%20work.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20managed%20property%20set%20to%20allow%20searching%2C%20refining%2C%20querying%2C%20the%20works.%20Any%20idea%20what%20else%20I%20need%20to%20do%20to%20get%20the%20simply%20query%20%22test1234%22%20to%20return%20results%20just%20like%20%22TellerNumber%3Atest1234%22%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESharePoint%202016.%20Thanks%20in%20advance!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-674717%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Server%202016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EUser%20Profile%20Service%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-686528%22%20slang%3D%22en-US%22%3ERe%3A%20Custom%20profile%20property%20doesn't%20return%20Search%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-686528%22%20slang%3D%22en-US%22%3E%3CP%3EIs%20the%20privacy%20setting%20on%20the%20custom%20user%20profile%20property%20set%20to%20%22Everyone%22%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi all, I have a custom user profile property called "TellerNumber." I have crawled and set it up as a managed property (and full crawled again). But when my search query targets the values in this property, I only get results if I explicitly tell Search to target that property:

 

Works:works.png

 

 

Doesn't work:doesn't work.png

 

I have the managed property set to allow searching, refining, querying, the works. Any idea what else I need to do to get the simply query "test1234" to return results just like "TellerNumber:test1234"?

 

SharePoint 2016. Thanks in advance!

1 Reply
Highlighted

Is the privacy setting on the custom user profile property set to "Everyone"?