Creating page does not save changes

Occasional Contributor

Issue is with one subsite under my sharepoint site.
I am trying to create a page, I choose gear icon -> add page -> i choose the saved template.
It starts auto saving, i.e 'draft not saved' text keeps refreshing and it creates multiple duplicates under site pages library.
'Save as draft' option gives error saying, "changes not saved". 
However, if i refresh the page, issue gets resolved.

Under console i see this error message: Failed to load resource: the server responded with a status of 400 (CopyWithConfiguration)
"{"odata.error":{"code":"-2147024809, System.ArgumentException","message":{"lang":"en-US","value":"Invalid data has been used to update the list item. The field you are trying to update may be read only."}}}"

However, if i select a blank template instead of a saved template, the issue does not occur.

This is not happening in any of other subsites.

Few days back, under same site, I had deleted a custom column named topic and added back new topic column by assigning it to respective items.  Not sure if this is causing the issue. 

Can anyone help me through this

6 Replies

@Ashwin_CH 


It seems that something wrong with your template.


Could you please try to update your template page and check whether you are able to update template page or not?

 


Hope it will helpful to you and if so then Please mark my response as Best Response & Like to help others in this community

Can you please tell me what exactly I will have to update in the template.

@Ashwin_CH 

 

You can try update anything in the page and also tried to update some column values to just validate whether template page is getting saved when we update any thing in the page and updating some column values

I deleted the webpart and added it back, I updated certain columns and tried again still same issue.
Errors are:
Failed to load resource:/sites/HSAHandbooks/CFS%20Online/_api/sitepages/pages(3591)/CopyWithConfiguration:1
failed to the server responded with a status of 400 ()

sp-pages-assembly_en-us_d94f37b93bd89431cd17fd3dc3edb457.js:70
POST https://smcgov.sharepoint.com/sites/HSAHandbooks/CFS%20Online/_api/sitepages/pages(3591)/CopyWithCon... 400
@Ashwin_CH

Did you manage to solve this issue?

I am experiencing the same problem, and it seems that others in the community have experienced the same, but unfortunetely I find no solution anywhere.

I tried to save another document as template, but still no luck. I did some changes to the columns as well... did you find out if this was related?

Thank you in advance.