Communications Sites and Search Scopes

Iron Contributor


I have created a communications site and I want search to search across the site collection not just the communications site.


So if I go to site settings I find Search there and under that I find settings.


There I find the familiar search screen asking me to input the search results page and what scopes I want.


So far so good.


But the search box of my communications site does not have the drop down for the scopes nor does the results page I go to, on clicking the magnifying glass, is the one I sett in Site settings -> Search -> settings !


What am I doing wrong ?







6 Replies

Hi Nigel 


Unfortunately the old search settings have not been hooked up to the new modern sites and this is by design as they are most likely making it better. So currently there is no way to change the search box in the new modern pages or where they link too.


You are best off upvoting one of the topics or writing your own ideas over at user voice, these get reviewed each month and you can see what ideas are being worked on.


It is a great feature we need back!


Search Center user voice


Or create your own idea here


Kind Regards





Hi @Alex Bunning


Thanks for the response.


I have found a SPFx web part which is a search box which redirects to the classic search results webpage.


So it looks as if it possible.


Initial testing looks promising.






Initial testing 

Nice one @Nigel Price


That looks like a nice solution until they have updated the search functionality.


Kind regards

Alex Bunning

HI @Alex Bunning


Yes, unfortunately Microsoft withdraw functionality before they have the replacement functionality in place.


The new Search functionality was promised after Ignite and here we are at the end of November and still no sign of it.





Hi Nigel, thanks for update. Any clue when new search experience is about to pop up? Thx Jan

Here we are at the end of February and still no sign of the Search.


Sorry I have no inside information on when Search will be available @VesaJuvonen ?