cannot drag and drop the .sppkg in the App Catalog

Copper Contributor


I created a simple hello world web part by following the documentation. and i am stuck in the step where i have  to deploy  helloworld-webpart.sppkg in the App catalog. i can run the webpart in the localhost:4321 as well as in the share point workbench.

I cannot drag and drop the .sppkg file. Could you please guide me if i should make some changes in the settings. i thought i dont have the proper access to do that. But i found even with the administrator login i cannot drag and drop helloworld-webpart.sppkg.


can some one help me with this issue please!!

Thanks in advance!!


8 Replies
Are you getting any error when trying to upload the solution to the App Catalog?
What browser are you using? Does drag an drop work on a different library?

@Joel Rodrigues 


I am using chrome bowser. I don't find any errors. I also see the upload button is disabled in the App catalog screen. I simply cannot drag and drop the sppkg file. nothing happens when i do that!!



@Joel Rodrigues 


I tried drag and drop other files. it does not seems to be working either.

Does the account you're using have write permissions to the site? If you go to the sharepoint admin console, set the account as an admin for that collection

@Vani_metamicro so that's probably because the account has no permissions. Try this to add the account as a site collection admin user

@Joel Rodrigues 


It worked, Thank you very much. Now i can proceed further.

Glad it worked, thanks for confirming