SOLVED

Blank pages after deployment using the PnP PowerShell cmdlets august release

Highlighted
Contributor

Hi guys,

 

Since the august release of the PnP PowerShell cmdlets, I'm facing a really weird issue.
I developed a demo intranet solution for SharePoint Online containing a custom provisioning template and few other deployment steps.
When I deploy the solution using the august version of cmdlets (https://github.com/OfficeDev/PnP-PowerShell/releases/tag/2.6.1608.0), all my publishing pages and list default views are just blank pages with the following code inside:

 

var gearPage = document.getElementById('GearPage');
if(null != gearPage)
{
gearPage.parentNode.removeChild(gearPage);
document.title = "Error";
}

But when I deploy the solution using the June Intermediate 3 version, everything is OK. I really don't know what the problem could be.
I've suspected the custom master page but even if I go back to the seattle master page, the issue still remain.

For those who want to reproduce the issue, you can just follow the instructions here by deploying the solution in a new site collection: https://github.com/FranckyC/PnP/tree/feature-o365-starter-intranet/Solutions/Business.O365StarterInt...

 

Thanks for your help!

2 Replies
Highlighted
Best Response confirmed by Franck Cornu (Contributor)
Solution
Hi Frank, found the same after searching and tweeting i found out it has to do with the regional settings which where provisioned. You can read here more about the bug and solution you need to add the calendertype... https://github.com/OfficeDev/PnP-Sites-Core/issues/715 kr, Paul
Highlighted

Thanks @Deleted, it works now (I didn't see the opened issue). Thanks again!