Attempting To Change Site Title - Error Message requires classification

Respected Contributor

I created some sites (and the associated groups) using New-PnPSite cmdlet, without using the optional Classification attribute. When we try to change the Site Title or Description in the browser, we get a prompt that "Classification options for your group have changed. Please select the appropriate classification" . The UI to change the Site Classification is not visible.

Is this a known issue?

Is anyone else seeing this?

Any ideas on how to fix this?



@Erwin van Hunen @Vesa Juvonen

21 Replies

I was able to reproduce it with a site created through the UI. Which means it's not related to the PnP Cmdlet. It seems to be something in the backend/server side.


Did you enable Site Classifications and later disable it? I had it enabled, but disabled it to test the scenario. It could be that it goes wrong somewhere on the server side after disabling this, but this is just guessing. We have no control over the server side, nor the code that is running there.

Thanks for the confirmation and explanation of how it works. We never had site classification enabled. I have opened a support ticket with MS and the Support Engineer was able to replicate the problem in his tenant also. I have asked them to escalate this issue to the back end team.



Same problem here.

same Problem here!

Facing the same issue

I had another call with MS support on December 11 and they are working on getting this fixed. 

Any update? We're having the same problem.

As a work around, you can edit this in Outlook 2016
Thanks Dean, the work around through Outlook 2016 appears to have worked.

I have the same problem. Another work around is to do the changes with MS Teams.

Making changes in teams doesn’t work for me, because it’s not the classification I wanted to change, but just the logo. Still I tried to change the classification in teams.
I successfully changed the classification, but I was still not able to change the logo.

Same problem here. I only tried to change the Logo of the group:

Fehlermeldung Sharepoint Online.JPG

Same problem here. I only tried to change the Logo, but it doesn't work:

Fehlermeldung Sharepoint Online.JPG

I was trying to change the logo of a Group and received this message.  I was able to change the logo via Teams.

Yes, it works with Teams. Thanks.

Same problem when i want change the title !



I received the following on Dec 18th, 

Unfortunately we have not received any update from our next level regarding this issue and we are still trying our best to get this fixed as soon as possible.

Once I get any update from the next level team, I will contact you with the same.

I appreciate your patience.

Thank you for choosing Microsoft,

Have a nice day.