Apply-PnPProvisioningTemplate : The specified program requires a newer version of Windows

Highlighted
MVP

I'm getting the following error when trying to provision multiple lists into a site:

 

Apply-PnPProvisioningTemplate : The specified program requires a
newer version of Windows. (Exception from HRESULT: 0x8007047E)

 

The error is not consistent and it may happen at different stages of the provisioning.

The template only has list instances, and I was able to provision the lists to a few sites last week. But not anymore...

Does anyone have a clue why this may be happening?

 

 

 

2 Replies
Highlighted
By chance do you have more than 1 version of PnP PowerShell installed on your machine? Also, what version of the module are you using?
Highlighted

I did think about that and in fact I had 2 versions, but the issues remained after uninstalling one.

Using latest PnP powerShell release as of today.

 

Interestingly, if I simply create the lists first and then apply the template, it seems to work.