App missing from Site Contents Page, Can't get to Classic view

%3CLINGO-SUB%20id%3D%22lingo-sub-197756%22%20slang%3D%22en-US%22%3EApp%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-197756%22%20slang%3D%22en-US%22%3E%3CP%3ELooking%20for%20help!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20working%20in%20a%20Communications%20Site%20that%20has%20two%20custom%20apps%20installed.%26nbsp%3B%20In%20the%20Site%20Contents%20page%2C%20however%2C%20it%20is%20only%20showing%20one%20of%20them%20duplicated.%26nbsp%3B%20I%20wanted%20to%20go%20into%20Classic%20Mode%20to%20see%20if%20it%20showed%20the%20same%20thing%2C%20but%20in%20a%20Communication%20Site%2C%20there%20is%20no%20longer%20a%20left%20navigation%20and%20thus%20there%20is%20no%20way%20to%20go%20into%20classic%20mode%20for%20the%20Site%20Contents%20page%20in%20order%20to%20troubleshoot.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20run%20into%20this%3F%26nbsp%3B%20How%20can%20I%20get%20to%20the%20Classic%20view%20of%26nbsp%3Bthe%20site%20contents%3F%26nbsp%3B%20Or%20at%20least%20have%20a%20different%20view%20of%20the%20apps%20installed%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHaven't%20tried%26nbsp%3BPowerShell.%26nbsp%3B%20Will%20check%20that%20next%20%3A-).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EMary%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-198656%22%20slang%3D%22en-US%22%3ERe%3A%20App%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-198656%22%20slang%3D%22en-US%22%3E%3CP%3EOkay%2C%20got%20it.%26nbsp%3B%20I%20had%20forgotten%20about%20the%20%22classic%22%20vs.%20%22modern%22%20cookie.%26nbsp%3B%20If%20you%20need%20to%20get%20back%20to%20the%20classic%20mode%20in%20a%20communication%20site%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOpen%20a%20debugging%20console%20while%20viewing%20the%20page.%3C%2FP%3E%3CP%3EExecute%20this%20via%20the%20command%20line%3A%3C%2FP%3E%3CPRE%3E%3CSPAN%20class%3D%22pln%22%3Ejavascript%3C%2FSPAN%3E%3CSPAN%20class%3D%22pun%22%3E%3A%3C%2FSPAN%3E%3CSPAN%20class%3D%22pln%22%3Edocument%3C%2FSPAN%3E%3CSPAN%20class%3D%22pun%22%3E.%3C%2FSPAN%3E%3CSPAN%20class%3D%22pln%22%3Ecookie%20%3C%2FSPAN%3E%3CSPAN%20class%3D%22pun%22%3E%3D%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22str%22%3E%22splnu%20%3D%200%3B%20path%3D%2F%22%3C%2FSPAN%3E%3C%2FPRE%3E%3CP%3ERefresh%20the%20page.%26nbsp%3B%20If%20the%20%22%2F%22%20path%20doesn't%20work%2C%20try%20a%20relative%20path%20to%20your%20site.%3C%2FP%3E%3CP%3EThe%20key%20is%20the%20%22splnu%22%20cookie%20value%20of%200.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-198387%22%20slang%3D%22en-US%22%3ERe%3A%20App%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-198387%22%20slang%3D%22en-US%22%3E%3CP%3ENope.%26nbsp%3B%20Didn't%20work.%26nbsp%3B%20I%20still%20do%20not%20get%20a%20left%20navigation%20for%20the%26nbsp%3B%3CSTRONG%3Emodern%3C%2FSTRONG%3E%20view%20of%20the%20Site%20Contents%20page.%26nbsp%3B%20But%20I%20don't%20really%20need%20the%20left%20navigation.%26nbsp%3Bexcept%20to%20access%20the%20%22Return%20to%20Classic%20SharePoint%22%20link%20at%20the%20bottom%20of%20the%20left%20navigation%20in%20modern%20sites.%26nbsp%3B%20And%20I%20only%20need%20to%20return%20to%20Classic%20mode%20temporarily%20to%20fix%20the%20Apps%20that%20are%20installed.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-198378%22%20slang%3D%22en-US%22%3ERe%3A%20App%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-198378%22%20slang%3D%22en-US%22%3E%3CP%3EI%20did%20the%20same%20Updated%20Site%20Layout%20to%20Seattle%20by%20using%20Classic%20Change%20the%20look%20option%20and%20i%20see%20my%20left%20navigation%20in%20Site%20Contents.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F35011iBCC48313F453667F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Comm1.PNG%22%20title%3D%22Comm1.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EHome%20Page%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F35012iBE324023DB2F070B%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Comm2.PNG%22%20title%3D%22Comm2.PNG%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3ESite%20Contents%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-198375%22%20slang%3D%22en-US%22%3ERe%3A%20App%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-198375%22%20slang%3D%22en-US%22%3E%3CP%3EHmm.%26nbsp%3B%20When%20I%20click%20change%20the%20look%20in%20a%20Modern%20Site%20(including%20a%20Communication%20Site)%2C%20I%20get%20the%20%22Modern%22%20change%20the%20look.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20192px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F35010i052DBEE4D48B08C1%2Fimage-dimensions%2F192x410%3Fv%3D1.0%22%20width%3D%22192%22%20height%3D%22410%22%20alt%3D%22ModernChangeLook.png%22%20title%3D%22ModernChangeLook.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThere%20is%20no%20option%20to%20change%20the%20layout.%26nbsp%3B%20If%20I%20click%20the%20link%20to%20go%20to%20the%26nbsp%3BClassic%20Change%20the%20look%2C%20the%20Site%20Layout%20is%20already%20set%20to%20Seattle.%26nbsp%3B%20But%20the%20Site%20Contents%20has%20no%20left%20nav.%26nbsp%3B%20It%20is%20displayed%20across%20the%20top%20without%20the%20option%20to%20go%20to%20%22Classic%22%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F35009iF846AA3510FF6394%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22NoLeftNavContentsPage.png%22%20title%3D%22NoLeftNavContentsPage.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-197986%22%20slang%3D%22en-US%22%3ERe%3A%20App%20missing%20from%20Site%20Contents%20Page%2C%20Can't%20get%20to%20Classic%20view%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-197986%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EClick%20the%20cog%20wheel%20on%20top%20right%20corner%20and%26nbsp%3B%20Change%20the%20look%20%2C%20Update%20Site%20Layout%20From%20Oslo%20master%20page%20to%20Seattle%20and%20my%20left%20navigation%20is%20back%20on%20Communication%20Site%20for%20Site%20Contents%20and%20Documents.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Looking for help!

 

We are working in a Communications Site that has two custom apps installed.  In the Site Contents page, however, it is only showing one of them duplicated.  I wanted to go into Classic Mode to see if it showed the same thing, but in a Communication Site, there is no longer a left navigation and thus there is no way to go into classic mode for the Site Contents page in order to troubleshoot.

 

Has anyone else run into this?  How can I get to the Classic view of the site contents?  Or at least have a different view of the apps installed?

 

Haven't tried PowerShell.  Will check that next :-).

 

Thanks,

Mary

5 Replies
Highlighted

Click the cog wheel on top right corner and  Change the look , Update Site Layout From Oslo master page to Seattle and my left navigation is back on Communication Site for Site Contents and Documents.

Highlighted

Hmm.  When I click change the look in a Modern Site (including a Communication Site), I get the "Modern" change the look.  

ModernChangeLook.png

There is no option to change the layout.  If I click the link to go to the Classic Change the look, the Site Layout is already set to Seattle.  But the Site Contents has no left nav.  It is displayed across the top without the option to go to "Classic":

 

NoLeftNavContentsPage.png

 

Highlighted

I did the same Updated Site Layout to Seattle by using Classic Change the look option and i see my left navigation in Site Contents.

 

Home PageHome PageSite ContentsSite Contents

Highlighted

Nope.  Didn't work.  I still do not get a left navigation for the modern view of the Site Contents page.  But I don't really need the left navigation. except to access the "Return to Classic SharePoint" link at the bottom of the left navigation in modern sites.  And I only need to return to Classic mode temporarily to fix the Apps that are installed. 

Highlighted

Okay, got it.  I had forgotten about the "classic" vs. "modern" cookie.  If you need to get back to the classic mode in a communication site:

 

Open a debugging console while viewing the page.

Execute this via the command line:

javascript:document.cookie = "splnu = 0; path=/"

Refresh the page.  If the "/" path doesn't work, try a relative path to your site.

The key is the "splnu" cookie value of 0.