A different version of this App is already installed with the same version number.

%3CLINGO-SUB%20id%3D%22lingo-sub-70867%22%20slang%3D%22en-US%22%3EA%20different%20version%20of%20this%20App%20is%20already%20installed%20with%20the%20same%20version%20number.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-70867%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI'm%20getting%20this%20error%20deploying%20an%20spfx%20app%3A%3C%2FP%3E%3CDIV%20class%3D%22ms-pr%22%3E%3CDIV%3ESorry%2C%20something%20went%20wrong%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CDIV%3E%3CDIV%3E%3CDIV%3E%3CSPAN%3EA%20different%20version%20of%20this%20App%20is%20already%20installed%20with%20the%20same%20version%20number.%26nbsp%3B%20You%20need%20to%20delete%20the%20app%20from%20the%20site%20and%20the%20site%20recycle%20bin%20to%20install%20this%20version.%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20the%20past%20i%20just%20deleted%20it%20from%20the%20first%20and%20second%20stage%20recycle%20bin.%20I%20tried%20that%20this%20time%20and%20it%20did%20not%20work%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20chnaging%20my%20version%20number%20in%20the%20manifest%20and%20redeploying.%20That%20did%20not%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20are%20the%20next%20steps%20to%20get%20my%20app%20deployed%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-70919%22%20slang%3D%22en-US%22%3ERe%3A%20A%20different%20version%20of%20this%20App%20is%20already%20installed%20with%20the%20same%20version%20number.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-70919%22%20slang%3D%22en-US%22%3E%3CP%3Eyou%20have%20to%20wait%20for%20couple%20of%20minutes.%20then%20remove%20the%20app%20from%20the%20appcatalog%20and%20then%20try%20adding%20the%20app%20again%20and%20it%20should%20work%20normal.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20general%2C%20if%20the%20GUID%20is%20not%20changed%20then%20it%20will%20do%20an%20auto%20update%20to%20all%20the%20site%20collections%20when%20we%20replace%20the%20app%20in%20the%20app%20catalog.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2362490%22%20slang%3D%22en-US%22%3ERe%3A%20A%20different%20version%20of%20this%20App%20is%20already%20installed%20with%20the%20same%20version%20number.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2362490%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F8901%22%20target%3D%22_blank%22%3E%40Russell%20Gove%3C%2FA%3E%26nbsp%3B%20If%20you%20delete%20the%20application%3C%2FP%3E%3CP%3Ethen%20please%20do%20the%20following%20steps%3C%2FP%3E%3COL%3E%3CLI%3Edelete%20the%20app%20from%20%3CSTRONG%3Erecycle%20bin%3C%2FSTRONG%3E%3COL%3E%3CLI%3Esite%20contents%26nbsp%3B%3C%2FLI%3E%3CLI%3Erecycle%20bin%20(top%20right%20corner))%3C%2FLI%3E%3CLI%3Eselect%20the%20app%20and%20delete%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3CLI%3Edelete%20the%20app%20from%20the%26nbsp%3B%3CSTRONG%3Esecond-stage%20recycle%20bin%3C%2FSTRONG%3E%26nbsp%3B%3COL%3E%3CLI%3Ego%20to%20site%20contents%26nbsp%3B%3C%2FLI%3E%3CLI%3Ego%20to%20recycle%20bin%20(top%20right%20corner))%3C%2FLI%3E%3CLI%3Eselect%20second-stage%20recycle%20bin%20(bottom%20left%20corner)%3C%2FLI%3E%3CLI%3Ethen%20delete%20app%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

Hi,

I'm getting this error deploying an spfx app:

Sorry, something went wrong
 
 
A different version of this App is already installed with the same version number.  You need to delete the app from the site and the site recycle bin to install this version.

 

 

In the past i just deleted it from the first and second stage recycle bin. I tried that this time and it did not work,

 

I tried chnaging my version number in the manifest and redeploying. That did not work.

 

What are the next steps to get my app deployed?

2 Replies

you have to wait for couple of minutes. then remove the app from the appcatalog and then try adding the app again and it should work normal.

 

In general, if the GUID is not changed then it will do an auto update to all the site collections when we replace the app in the app catalog.

@Russell Gove  If you delete the application

then please do the following steps

  1. delete the app from recycle bin
    1. site contents 
    2. recycle bin (top right corner))
    3. select the app and delete
  2. delete the app from the second-stage recycle bin 
    1. go to site contents 
    2. go to recycle bin (top right corner))
    3. select second-stage recycle bin (bottom left corner)
    4. then delete app