Home

Navigation in hubsites

%3CLINGO-SUB%20id%3D%22lingo-sub-175123%22%20slang%3D%22en-US%22%3ENavigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-175123%22%20slang%3D%22en-US%22%3E%3CP%3EHello%3C%2FP%3E%0A%3CP%3EI%20have%20created%20a%20new%20team%20site%20then%20promoted%20it%20to%20a%20hub%20site.%20The%20I%20associated%20a%20communication%20site%20to%20hubsite.%20No%20changes%20to%20navigation%20yet.%20I%20don't%20see%20top%20nav%20appear%20in%20both%20hub%20site%20and%20also%20in%20the%20associated%20site%20yet.%20Has%20hub%20site%20nav%20functionality%20rollout%20to%20target%20tenants%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAlso%20another%20question%20about%20navigation%3A%3C%2FP%3E%0A%3CP%3EIf%20the%20associated%20site%20has%20subsites%2C%20is%20there%20a%20way%20to%20make%20them%20appear%20in%20hub%20site%20navigation%3F%3C%2FP%3E%0A%3CP%3EThanks%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-175123%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-177809%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-177809%22%20slang%3D%22en-US%22%3ENo%20you%20don't%20need%20to%20activate%20anything.%20Go%20to%20your%20hub%20site%20and%20build%20out%20your%20navigation%20structure.%20After%20some%20time%2C%20this%20navigation%20structure%20will%20appear%20on%20all%20the%20sites%20associated%20with%20the%20hub%20site.%20It%20is%20not%20immediate.%20These%20seems%20to%20some%20sort%20of%20backend%20timer%20job%20that%20synchronizes%20the%20navigation%20across%20all%20sites.%20In%20my%20case%2C%20it%20took%20about%201%20hour%20to%20see%20the%20nav%20changes%20on%20all%20associates%20sites.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-177748%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-177748%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%20i%20seem%20to%20have%20the%20same%20outcome.%20It%20is%20confusing%20in%20being%20able%20to%20run%20the%20PowerShell%20commandlets%20successfully%20yet%20the%20new%20navigation%20does%20not%20appear%20for%20the%20registered%20hub%20site.%26nbsp%3B%20Does%20it%20mean%20Hub%20Sites%20are%20partially%20available%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-177702%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-177702%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20don't%20need%20to%20activate%20anything...adding%20here%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F5852%22%20target%3D%22_blank%22%3E%40Melissa%20Torres%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-177690%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-177690%22%20slang%3D%22en-US%22%3E%3CP%3EHubsites%20are%20rolled%20out%20to%20all%20TR%2C%20but%20I%20still%20don't%20see%20any%20navigation%20changes.%3C%2FP%3E%0A%3CP%3EDo%20I%20need%20to%20activate%20this%20somewhere%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-175160%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-175160%22%20slang%3D%22en-US%22%3Eif%20you%20aren't%20seeing%20the%20nav%20set%20yet%2C%20the%20feature%20has%20not%20yet%20been%20enabled%20in%20your%20tenant.%20We%20are%20enabling%20for%20all%20targeted%20release%20tenants%2C%20but%20it%20takes%20a%20few%20days%20to%20get%20everywhere.%3CBR%20%2F%3E%3CBR%20%2F%3Eon%20subsites%20--%20the%20hub%20navigation%20is%20manually%20curated%20by%20the%20hub%20owner.%20you%20are%20welcome%20to%20add%20links%20to%20any%20subsites%2C%20but%20we%20don't%20automate%20that%20process.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-836038%22%20slang%3D%22en-US%22%3ERe%3A%20Navigation%20in%20hubsites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-836038%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue%20regarding%20a%20hub%20site%20on%20our%20tenant.%20The%20shared%20navigation%20is%20simply%20not%20showing%20on%20sites%20connected%20to%20the%20hub.%20Publishing%20Infrastructure%20is%20not%20on%20on%20any%20of%20these%20sites%2C%20but%20after%20a%20week%20navigation%20is%20simply%20not%20showing%20up.%20We%20are%20using%20team%20and%20communications%20sites%2C%20all%20of%20them%20working%20with%20modern%20pages.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hello

I have created a new team site then promoted it to a hub site. The I associated a communication site to hubsite. No changes to navigation yet. I don't see top nav appear in both hub site and also in the associated site yet. Has hub site nav functionality rollout to target tenants?

 

Also another question about navigation:

If the associated site has subsites, is there a way to make them appear in hub site navigation?

Thanks

 

5 Replies
Highlighted
if you aren't seeing the nav set yet, the feature has not yet been enabled in your tenant. We are enabling for all targeted release tenants, but it takes a few days to get everywhere.

on subsites -- the hub navigation is manually curated by the hub owner. you are welcome to add links to any subsites, but we don't automate that process.
Highlighted

Hubsites are rolled out to all TR, but I still don't see any navigation changes.

Do I need to activate this somewhere?

 

Highlighted

You don't need to activate anything...adding here @Melissa Torres 

Highlighted

Hello, i seem to have the same outcome. It is confusing in being able to run the PowerShell commandlets successfully yet the new navigation does not appear for the registered hub site.  Does it mean Hub Sites are partially available?

Highlighted
No you don't need to activate anything. Go to your hub site and build out your navigation structure. After some time, this navigation structure will appear on all the sites associated with the hub site. It is not immediate. These seems to some sort of backend timer job that synchronizes the navigation across all sites. In my case, it took about 1 hour to see the nav changes on all associates sites.