Organizational data upload error

Silver Contributor

Hi everyone,

I'm running into an odd error when uploading organizational data, so I thought I'd reach out to this community to see if anyone has run into this issue before, or has any ideas how to resolve it. Highlighted in the screenshot below, I've been working with an organization to re-structure their org data file to support a very specific use case, but when we uploaded a new organizational data file, we were met with the following error:

"An error occurred during processing. The cause is being investigated. When the error is resolved, this message will update accordingly." 

What's odd is that it's been sitting like this for just over 24 hours, and there is no error log to investigate or download. Even more frustrating, we can't initiate a new upload. Has anyone run into this issue before? 



8 Replies

I am getting the same error message for the first time. I would love if anyone has a solution for this as well!

Hi @VI_Migration and @VI_Migration, this sometimes happens to clients. It is a cue for engineering from Microsoft to look into the issue and investigate what is going on. It can be tough because Viva does not provide any error message or reasoning behind why the problem is happening. Typically engineering will resolve the issue within a few days but if not there may be a bigger issue going on. 

Are these issues still outstanding for both of you? 

Hey @Jake_Caddes - thanks for the follow up. 

Unfortunately we're still dealing with this issue on our end. We did report a bug on Tuesday, and it sounds like like engineering is working on this as we speak, so hopefully we see a fix early next week! 

Any idea what might have caused it? I'm worried we'll run into the same issue when trying to re-upload an org data file. We have some tight timelines for this work, so another week like this could create friction. 

Hi @VI_Migration, it would be hard to tell without taking a look at the Org File. I would recommend to make sure that the upload had all of the correct formatting because that is the most common issue clients face. 

Here is some more documentation on the formatting rules: Prepare organizational data in Workplace Analytics | Microsoft Docs

Hey @VI_Migration I've been told to submit a bug in Workplace Analytics to flag the issue for engineering. 

Easiest way to do that is by clicking on the smiley face in the top right, and following the prompts from there. Make sure you include an email address you check often, as they'll use that email to share and send updates. 

Thanks @Jake_Caddes

Are you confident it has to do with the Org File? I've worked through this process a few times now, in several different tenants, and I've never seen this error before. Usually there's a message or notification stating the Org Data upload failed because of missing fields or formatting issues, with a log included to highlight issues. This seems to be an entirely different experience. 

Just asking as I'd hate to run into the issue again, we've already lost a week of analysis time... 

best response confirmed by Jake_Caddes (Microsoft)

@VI_Migration , I think I know what caused this!

Our issue is was caused by the FileName containing a '#' so make sure you remove this moving forward. You'll still need to flag the issue with Engineering so they can reset the upload, which you can do using the instructions I shared in my last reply. 

Hope that helps! 

We had an issue too, but after two weeks thinking, it resolved itself.  So I still have no idea what caused the issue.  Though I do wonder if it was due to originally having less than 5 licences.