Home

Creating a new App Registration in Azure, app disappears

%3CLINGO-SUB%20id%3D%22lingo-sub-147045%22%20slang%3D%22en-US%22%3ECreating%20a%20new%20App%20Registration%20in%20Azure%2C%20app%20disappears%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147045%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20a%20specific%20Azure%20tenant%2C%20when%20I%20create%20a%20new%20app%20registration%2C%20it%20just%20disappears%20and%20is%20nowhere%20to%20be%20found.%3C%2FP%3E%0A%3CP%3EIt%20gets%20assigned%20an%20application%20id%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fi.stack.imgur.com%2FwHycu.png%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fi.stack.imgur.com%2FwHycu.png%22%20border%3D%220%22%20alt%3D%22enter%20image%20description%20here%22%20%2F%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EI%20am%20also%20able%20to%20create%20a%20key%20for%20it%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fi.stack.imgur.com%2FKsyn3.png%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fi.stack.imgur.com%2FKsyn3.png%22%20border%3D%220%22%20alt%3D%22enter%20image%20description%20here%22%20%2F%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3Eand%20view%20properties%20for%20it%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fi.stack.imgur.com%2FNXVG6.png%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fi.stack.imgur.com%2FNXVG6.png%22%20border%3D%220%22%20alt%3D%22enter%20image%20description%20here%22%20%2F%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EBut%20when%20I%20go%20to%20refresh%20the%20list%20of%20apps%20(or%20go%20somewhere%20else%20to%20pick%20it%20for%20identity%20access%20control)%20-%20it%20is%20just%20nowhere%20to%20be%20found.%20Like%20this%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fi.stack.imgur.com%2F7LM5w.gif%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fi.stack.imgur.com%2F7LM5w.gif%22%20border%3D%220%22%20alt%3D%22enter%20image%20description%20here%22%20%2F%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EIf%20I%20go%20to%20Azure%20Active%20Directory%20Overview%2C%20it%20says%20I%20have%204%20applications%20(which%20fits%20the%20number%20of%20times%20I%20have%20create%20a%20new%20app%20registration)%20-%20but%20if%20I%20click%20it%20-%20nothing%20found.%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fi.stack.imgur.com%2FPjSfj.gif%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fi.stack.imgur.com%2FPjSfj.gif%22%20border%3D%220%22%20alt%3D%22enter%20image%20description%20here%22%20%2F%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3ENote%3A%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3EThe%20account%20I%20am%20using%20is%20a%20global%20admin%3C%2FLI%3E%0A%3CLI%3EI%20have%20also%20tried%20doing%20this%20with%20the%20owner%20account%20of%20this%20tenant%2C%20same%20result%3C%2FLI%3E%0A%3CLI%3EThis%20works%20in%20all%20other%20tenants%3C%2FLI%3E%0A%3CLI%3EI%20have%20tried%20logging%20out%20and%20back%20in%3C%2FLI%3E%0A%3CLI%3EI%20have%20waited%20(days)%2C%20does%20not%20change%20anything%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CH2%20id%3D%22toc-hId-1619854749%22%20id%3D%22toc-hId-1793361343%22%3EWhat%20is%20happening%3F%3C%2FH2%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-147045%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Active%20Directory%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-149610%22%20slang%3D%22en-US%22%3ERe%3A%20Creating%20a%20new%20App%20Registration%20in%20Azure%2C%20app%20disappears%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-149610%22%20slang%3D%22en-US%22%3E%3CP%3EThat's%20a%20bad%20choice%20for%20UI.%20It%20tried%20to%20find%20my%20newly%20created%20apps%20for%20a%20few%20hours.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F43428%22%20target%3D%22_blank%22%3E%40Kent%20Gaardmand%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-147454%22%20slang%3D%22en-US%22%3ERe%3A%20Creating%20a%20new%20App%20Registration%20in%20Azure%2C%20app%20disappears%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-147454%22%20slang%3D%22en-US%22%3E%3CP%3EChange%20the%20filter%20to%20display%20all%20apps%2C%20you%20have%20it%20set%20to%20%22My%20apps%22%20this%20list%20is%20for%20user%20specific%20approved%20apps.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Klaus Jensen
Occasional Visitor

For a specific Azure tenant, when I create a new app registration, it just disappears and is nowhere to be found.

It gets assigned an application id:

enter image description here

I am also able to create a key for it:

enter image description here

and view properties for it:

enter image description here

But when I go to refresh the list of apps (or go somewhere else to pick it for identity access control) - it is just nowhere to be found. Like this:

enter image description here

If I go to Azure Active Directory Overview, it says I have 4 applications (which fits the number of times I have create a new app registration) - but if I click it - nothing found.

enter image description here

Note:

  • The account I am using is a global admin
  • I have also tried doing this with the owner account of this tenant, same result
  • This works in all other tenants
  • I have tried logging out and back in
  • I have waited (days), does not change anything

What is happening?

2 Replies

Change the filter to display all apps, you have it set to "My apps" this list is for user specific approved apps.

That's a bad choice for UI. It tried to find my newly created apps for a few hours.

 

Thanks @Kent Gaardmand

Related Conversations