SOLVED

A user's Azure MFA Authentication methods shows differently to admins

%3CLINGO-SUB%20id%3D%22lingo-sub-1920254%22%20slang%3D%22en-US%22%3EA%20user's%20Azure%20MFA%20Authentication%20methods%20shows%20differently%20to%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1920254%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Folks%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20a%20reason%20why%20Azure%20user's%20MFA%20registered%20authentication%20methods%20shows%20differently%20to%20admins%3F%26nbsp%3B%20A%20user%20can%20see%20all%20his%20registered%20methods%20through%20the%20security%20info%20but%20azure%20admins%20sees%20only%20a%20single%20method.%20Tried%20a%20resetting%20MFA%20and%20even%20with%20a%20brand%20new%20set%20of%20users%2Fadmins%20but%20its%20all%20behaves%20the%20same.%20Any%20ideas%20appreciated%20!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdmin%20View%20-%20AAD%20Portal%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22admin_view.jpg%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F235341iE18A129A393CD4D1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22admin_view.jpg%22%20alt%3D%22admin_view.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUser%20View%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Faka.ms%2Fsetupsecurityinfo%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2Fsetupsecurityinfo%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22user_View.jpg%22%20style%3D%22width%3A%20573px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F235343i346E8796F3C73F89%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22user_View.jpg%22%20alt%3D%22user_View.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1920254%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Active%20Directory%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIdentity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMulti-Factor%20Authentication%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1920371%22%20slang%3D%22en-US%22%3ERe%3A%20A%20user's%20Azure%20MFA%20Authentication%20methods%20shows%20differently%20to%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1920371%22%20slang%3D%22en-US%22%3EIt's%20normal%20that%20admins%20don't%20see%20the%20Authenticator%20app%20for%20a%20user.%3CBR%20%2F%3EYou%20can%20retrieve%20this%20through%20Powershell%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsamples%2Fazure-samples%2Fazure-mfa-authentication-method-analysis%2Fazure-mfa-authentication-method-analysis%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsamples%2Fazure-samples%2Fazure-mfa-authentication-method-analysis%2Fazure-mfa-authentication-method-analysis%2F%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1920409%22%20slang%3D%22en-US%22%3ERe%3A%20A%20user's%20Azure%20MFA%20Authentication%20methods%20shows%20differently%20to%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1920409%22%20slang%3D%22en-US%22%3EIn%20addition%20to%20the%20previous%20reply%20you%20can%20read%20more%20about%20it%20in%20the%20attached%20link.%20As%20you%E2%80%99ll%20see%20the%20information%20is%20%E2%80%9Dkept%20private%E2%80%9D%20as%20default.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fauthentication%2Fhowto-mfa-userdevicesettings%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fauthentication%2Fhowto-mfa-userdevicesettings%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1921331%22%20slang%3D%22en-US%22%3ERe%3A%20A%20user's%20Azure%20MFA%20Authentication%20methods%20shows%20differently%20to%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1921331%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20prompt%20response%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F551905%22%20target%3D%22_blank%22%3E%40bec064%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F186539%22%20target%3D%22_blank%22%3E%40Thijs%20Lecomte%3C%2FA%3E%26nbsp%3B%20Appreciate%20it%20!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi Folks, 

 

Is there a reason why Azure user's MFA registered authentication methods shows differently to admins?  A user can see all his registered methods through the security info but azure admins sees only a single method. Tried a resetting MFA and even with a brand new set of users/admins but its all behaves the same. Any ideas appreciated ! 

 

Admin View - AAD Portal 

admin_view.jpg

 

User View https://aka.ms/setupsecurityinfo 

user_View.jpg

3 Replies
Best Response confirmed by Manoj Karunarathne (Contributor)
Solution
It's normal that admins don't see the Authenticator app for a user.
You can retrieve this through Powershell: https://docs.microsoft.com/en-us/samples/azure-samples/azure-mfa-authentication-method-analysis/azur...
In addition to the previous reply you can read more about it in the attached link. As you’ll see the information is ”kept private” as default.

https://docs.microsoft.com/en-us/azure/active-directory/authentication/howto-mfa-userdevicesettings

Thanks for the prompt response @bec064 @Thijs Lecomte  Appreciate it !