TLS 1.0 and TLS 1.1 support discontinued on packages.microsoft.com

%3CLINGO-SUB%20id%3D%22lingo-sub-1623892%22%20slang%3D%22en-US%22%3ETLS%201.0%20and%20TLS%201.1%20support%20discontinued%20on%20packages.microsoft.com%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1623892%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3E%3CBR%20%2F%3EMicrosoft%20builds%20and%20supports%20a%20variety%20of%20software%20products%20for%20Linux%20systems%20and%20makes%20them%20available%20via%20package%20repositories%20on%20packages.microsoft.com.%20To%20support%20modern%20security%20standards%2C%20packages.microsoft.com%20will%20discontinue%20support%20for%20package%20downloads%20over%20Transport%20Layer%20Security%20(TLS)%201.0%20and%201.1%20protocols%20as%20of%20September%2024%2C%202020.%20This%20means%20that%20any%20connection%20using%20these%20protocols%20will%20no%20longer%20work%20as%20expected%2C%20and%20no%20support%20will%20be%20provided.%20In%20order%20to%20continue%20to%20access%20packages%20from%20packages.microsoft.com%20after%20that%20date%2C%20organizations%20will%20need%20to%20enable%20TLS%201.2.%20%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EWhere%20possible%2C%20Microsoft%20recommends%20that%20organizations%26nbsp%3B%3C%2FSPAN%3E%3CA%20class%3D%22focus-visible%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsecurity%2Fengineering%2Fsolving-tls1-problem%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%20data-linktype%3D%22absolute-path%22%20data-focus-visible-added%3D%22%22%3Eremove%20all%20TLS%201.0%20and%201.1%20dependencies%3C%2FA%3E%3CSPAN%3E%26nbsp%3Bin%20their%20environments%20and%20disable%20TLS%201.0%2F1.1%20at%20the%20operating%20system%20level.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Microsoft


Microsoft builds and supports a variety of software products for Linux systems and makes them available via package repositories on packages.microsoft.com. To support modern security standards, packages.microsoft.com will discontinue support for package downloads over Transport Layer Security (TLS) 1.0 and 1.1 protocols as of September 24, 2020. This means that any connection using these protocols will no longer work as expected, and no support will be provided. In order to continue to access packages from packages.microsoft.com after that date, organizations will need to enable TLS 1.2.

 

Where possible, Microsoft recommends that organizations remove all TLS 1.0 and 1.1 dependencies in their environments and disable TLS 1.0/1.1 at the operating system level.

0 Replies