Adobe Acrobat Reader plug-in - user email has to be entered every time

Occasional Contributor

I've been testing the Acrobat Reader plug-in to better show the assigned labels to users. No problem at all installing the client and plug-in, configuring unified labels, granting admin consent to the Acrobat Reader app in Azure AD, adding the registry key to automatically display the label.

 

What I can't resolve, and would dearly like to, is the requirement to enter the user's email address EVERY TIME a labelled PDF is accessed. I've signed in once, selected to save the user credentials to save time, and the relevant registry value is in place (bSaveCredentials = 1), but it makes no difference - if I then try to open a labelled PDF, I still get asked to enter email address.

 

This isn't user-friendly at all. Has anyone managed to resolve this so that it actually saves the credentials as it suggests it should?

 

As it stands, it's not fit-for-purpose and I know I will have clients that will not want to use this in its current state.

2 Replies

I've been investigating this further and the registry keys/values can be put under the local machine registry hive (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Adobe\Acrobat Reader\DC\MicrosoftAIP) instead of the current user, which under some circumstances may make deployment easier.

 

Unfortunately, the "enter your email address" prompt shows no sign of going.

 

Anyone from Microsoft/Adobe able to shed some light on this behaviour?

UPDATE: new versions of Acrobat Reader DC and the associated MIP add-in are available (as from 15 October 2019) and this issue has been resolved. No more email address prompt!