Secure score not updating since Feb 14

Frequent Contributor

My secure score has not been updated since Feb 14.  Has anyone else had this issue?  I have tried in 3 different browsers.



14 Replies

It's happening to my client too. It is not updated from the same date. not sure exactly why.

For my client too. 

O365 Support

@Deleted wrote:

It's happening to my client too. It is not updated from the same date. not sure exactly why.

I have the exact same issue.  Contacted support and they ran the re-synch process in the back-end yesterday.  As of now it still has not updated on my page either. 

Hi Everyone,


We are aware of the scoring data not being updated and are working on correcting this.  I currently see the data updated as of the 18th.

I also have this issue.
Hi Peter, The issue should be solved. My tenant shows a date of the 25th which is the latest date we have data for.

Hi Mike,


Can you please check if your tenant Security Score is now updated?




Hi Anthony,


My client wants to know if there is a time indication when Microsoft create or activate the telemetry for this control? Client did not receive the points for the configuration of Set outbound spam notification.



Hi Annalou,


That control is flagged as not scored.  This means that we don't have the telemetry wired up to the control yet and hence why your client (or anyone else) will get the points for it.  Once we wire this up everyone who has enabled this will get the points credited.

It is now updating. Thanks for sorting that out. However, it is incorrect. We have today lost 20 points due to "Enable Client Rules Forwarding Block" getting 0 even though that was implemented last week, was being credited and remains implemented. We have also not yet been credited with enabling MFA for all global admins, using audit data, designating less than 5 global admins and configuring an expiry time for external sharing links. The two related to admins were only implemented yesterday but the others were older. Not a huge issue given that there are a number of actions we've taken for which there is no telemetry yet so I'm working out our "real" score manually, but a bit frustrating.

I think it is a temporary rip in the time-space continuum.  I have the same, but I suspect that tomorrow it will be corrected.

Hi Peter,

Would you mind using the feedback button in Secure Score to report your problem?  I see similar issues in my tenant so I will push this up to the development team but having your feedback in the system helps the team troubleshoot the issue.