Privacy settings in Container classification labels not taking effect

New Contributor

I have configured sensitivity labels for containers 

Label Schema

1.Secret - Enabled with container classification ( Privacy settings = Private - only members can access)

2.Secret\Finance - label with admin permissions 

Policy Details :

I have a policy specific for finance where the secret and secret\finance will be published to finance users.

I have another policy where Secret\All users will be published to all the users 

 

I get all the labels correctly per design. 

Now, my goal is to create a site based on the label Secret and ensure non Finance members should not be able to download as per Microsoft article here 

Now, I created a Groups site by selecting the the sensitivity 'Secret'. The SharePoint site associated with the group site is not providing any sign of restrictions. It does not display any banners in the top as per the article. Instead, what it is giving is the regular "You do not have access to this site , request access". When I give access to the users as members, the site opens up without issues. 

 

Am I missing anything ? Please advise 

 

1 Reply

@balajee1985 Hello, two things. It will take some time for the container labels (groups, sites, teams) and the information provided in them to populate. When it comes to the banner message at top you have to configure the unmanaged devices option.

 

ChristianJBergstrom_0-1648301551832.png

 

So with the container label itself, i.e. without any other settings in the label, you cannot control the download part you're referring to.