Microsoft Office Professional Plus 2019 Version 1808 features requiring .NET 3.5, 4.6, or higher

%3CLINGO-SUB%20id%3D%22lingo-sub-2660287%22%20slang%3D%22en-US%22%3EMicrosoft%20Office%20Professional%20Plus%202019%20Version%201808%20features%20requiring%20.NET%203.5%2C%204.6%2C%20or%20higher%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2660287%22%20slang%3D%22en-US%22%3E%3CP%3EI%20only%20installed%20Word%2C%20Excel%2C%20and%20PowerPoint%2C%20so%20Access%2C%20OneNote%2C%20Outlook%2C%20Publisher%2C%20and%20Lync%2FSkype%20are%20not%20installed.%3CBR%20%2F%3EIs%20there%20a%20Microsoft%20documentation%20website%20that%20states%20Word%2C%20Excel%2C%20and%20PowerPoint%20do%20not%20require%20.NET%3F%3CBR%20%2F%3EWhat%20features%20of%20Office%202019%20require%20.NET%203.5%20or%204.6%3F%3CBR%20%2F%3EWhere%20are%20the%20.exe.config%20and%20.machine.config%20files%20when%20Office%202019%20is%20calling%20.NET%203.5%20or%204.6%3F%3CBR%20%2F%3EDoes%20Office%202019%20only%20utilize%20%22caspol.exe%22%20assembly%20or%20other%20assemblies%20provided%20with%20the%20Windows%20OS%20or%20the%20Windows%20Secure%20Host%20Baseline%20(SHB)%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EReferences%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fmicrosoft-365%2Fmicrosoft-365-and-office-resources%23coreui-heading-8i242k6%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fmicrosoft-365%2Fmicrosoft-365-and-office-resources%23coreui-heading-8i242k6%3C%2FA%3E%3CBR%20%2F%3E.NET%20version%3CBR%20%2F%3EWindows%3A%20Some%20features%20may%20require%20.NET%203.5%20or%204.6%20and%20higher%20to%20also%20be%20installed.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.stigviewer.com%2Fstig%2Fmicrosoft_dotnet_framework_4.0%2F2020-12-11%2Ffinding%2FV-225232%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.stigviewer.com%2Fstig%2Fmicrosoft_dotnet_framework_4.0%2F2020-12-11%2Ffinding%2FV-225232%3C%2FA%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.stigviewer.com%2Fstig%2Fmicrosoft_dotnet_framework_4.0%2F2020-12-11%2Ffinding%2FV-225236%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.stigviewer.com%2Fstig%2Fmicrosoft_dotnet_framework_4.0%2F2020-12-11%2Ffinding%2FV-225236%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I only installed Word, Excel, and PowerPoint, so Access, OneNote, Outlook, Publisher, and Lync/Skype are not installed.
Is there a Microsoft documentation website that states Word, Excel, and PowerPoint do not require .NET?
What features of Office 2019 require .NET 3.5 or 4.6?
Where are the .exe.config and .machine.config files when Office 2019 is calling .NET 3.5 or 4.6?
Does Office 2019 only utilize "caspol.exe" assembly or other assemblies provided with the Windows OS or the Windows Secure Host Baseline (SHB)?

 

 

References
https://www.microsoft.com/en-us/microsoft-365/microsoft-365-and-office-resources#coreui-heading-8i24...
.NET version
Windows: Some features may require .NET 3.5 or 4.6 and higher to also be installed.

https://www.stigviewer.com/stig/microsoft_dotnet_framework_4.0/2020-12-11/finding/V-225232
https://www.stigviewer.com/stig/microsoft_dotnet_framework_4.0/2020-12-11/finding/V-225236

0 Replies