MFA IP whitelist not working after enabling Conditional Access policy

Occasional Contributor

A new requirement for CSP partners is enabling conditional access policies "Baseline policy: Require MFA for admins" and "Baseline policy: End user protection".


We already have MFA enabled/enforced for all end users and admins, with IP whitelist for main office and soho. That worked fine.


But after enabling those CA policies our IP whitelist stopped working. End users at the office are asked for MFA, and our O365 backup running with global admin credentials can no longer login.


I tried to create our main office public IP as a trusted location, but no luck.


As a quick fix i disabled the policies while digging into this.


Can anybody explain why this is happening?

1 Reply

bugs bugs bugs...


We had similar issue more than half an year ago and no solution was provided.. :)


probably its quite complex, because problem is somewhere between azure ad and intune/mdm and sharepoint integration.. sometimes already enrolled devices are asked to enroll when they already are enrolled..


If you will get a solution - let us know too :)