Microsoft Entra Suite Tech Accelerator
Aug 14 2024, 07:00 AM - 09:30 AM (PDT)
Microsoft Tech Community

eDiscovery Content Search Export Action Has Failed on SharePoint Online content - (CS012-001)

Copper Contributor

Hi - I have tried all sorts of combinations but I am consistently getting an Export Action failure when trying a Search Export Action when running the Search and Export Action as an eDiscovery Manager.  The error impacts against SharePoint Online content but does NOT impact Exchange Online content.


I do NOT get the same error when running the Search & Export Action as an eDiscovery Administrator. Also, I do not get the error is I run the Export Action as an eDiscovery Administrator after running the search as an eDiscovery Manager but when I do this the # of items found increases??


The failure also results in an incomplete download of the Search Results and seemingly incorrect Search Report in that in both instances only Exchange content is downloaded/referenced in the report.


The failure is on the Export job in the portal and reads as follow: Scheduling export failed with 1 error: The export action has failed. Job:Application error occurred. Please make sure your keyword query syntax is correct and the conditions you chose are supported by the content sources you're searching. For example, if you're not searching any mailboxes, make sure you didn't choose any conditions supported only by mail. (CS012-001).


I am NOT using any queries when running the search.


The set up I currently have is below but I have tried many alternative set ups all with the same results.

1 x eDiscovery Administrator.

1 x eDiscovery Manager for Business Unit1

1 x eDiscovery Manager for Business Unit2.

Business Unit1 Compliance Boundary = 

FilterName  : BusinessUnit1_COMPLIANCE_BOUNDARY

Action      : All

Users       : {Business Unit1 ediscovery manager role}

Filters     : {Mailbox_Company -eq 'Business Unit1 Company Value', Site_Path -like


Region      :

Identity    :

IsValid     : True

ObjectState : New

Business Unit2 Compliance Boundary = 

FilterName  : BusinessUnit2_COMPLIANCE_BOUNDARY

Description :

Action      : All

Users       : {BusinessUnit2 ediscovery manager role}

Filters     : {Mailbox_Company -eq 'Business Unit1 Company ValueA' -or Mailbox_Company -eq 'Business Unit1 Company ValueB' -or Mailbox_Company -eq 'Business Unit1 Company ValueC', Site_Path -eq ' IanM_Communication_Site'}

Region      :

Identity    :

IsValid     : True

ObjectState : New


As the error does NOT occur for the eDiscovery Administrator I am thinking that it might be a permissions or Compliance Boundary (ComplianceSearchFilter) issue but I have tried a few alternative filters and the only permissions documentation I have been able to find refers to eDiscovery roles which is what I have used.


Has anyone else seen this error or if not can anyone make any suggestions on how I can resolve it please?



0 Replies