Microsoft Security Tech Accelerator
Dec 06 2023, 07:00 AM - 12:00 PM (PST)
Microsoft Tech Community

Creating a new App Registration in Azure, app disappears

Copper Contributor

For a specific Azure tenant, when I create a new app registration, it just disappears and is nowhere to be found.

It gets assigned an application id:

enter image description here

I am also able to create a key for it:

enter image description here

and view properties for it:

enter image description here

But when I go to refresh the list of apps (or go somewhere else to pick it for identity access control) - it is just nowhere to be found. Like this:

enter image description here

If I go to Azure Active Directory Overview, it says I have 4 applications (which fits the number of times I have create a new app registration) - but if I click it - nothing found.

enter image description here


  • The account I am using is a global admin
  • I have also tried doing this with the owner account of this tenant, same result
  • This works in all other tenants
  • I have tried logging out and back in
  • I have waited (days), does not change anything

What is happening?

2 Replies

Change the filter to display all apps, you have it set to "My apps" this list is for user specific approved apps.

That's a bad choice for UI. It tried to find my newly created apps for a few hours.


Thanks @Kent Gaardmand