Can't log into (asks me to sign into my Microsoft account — also not working)

New Contributor

Hello. Starting two weeks ago I lost the ability to access in any way:


  1. it should allow for anonymous viewing / reading, but is now asking me to log into my Microsoft account (this is when I'm fully logged out)
  2. I tried to log in using the credentials that I've been using for years now and it says that I don't have a "Microsoft" account using that email address (I have been logging in with my gmail account), so..
  3. I tried creating a Microsoft account for my gmail address and even then I get the same silly error message:

    Request Id: d521f059-5f46-4b8b-aace-f3a5f3419400
    Correlation Id: 07504db8-13e8-47a1-9dea-09ebe7227b9c
    Timestamp: 2020-09-17T19:58:34Z
    Message: AADSTS50020: User account '' from identity provider '' does not exist in tenant 'UserVoice, Inc.' and cannot access the application '91a42e81-999b-4cf1-aa36-bb33f25ff53b'( in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account.


I tried (on Windows 10) in both Edge and Chrome. I cleared my cookies in both, exited the browser and started them up again. I even see this behavior on my phone. None of this makes any sense so I assume that it's a problem with the site. I'm specifically trying to get to , but I can't even access .



I don't know if this is the most appropriate place to report such a problem (I wouldn't be surprised if it isn't), but I have no idea where else to go (neither nor seem appropriate). I did try posting this on but was suggested to try here instead.


If there is a more appropriate place to post this, please let me know. I'm also curious if anyone else is having this problem. It seems very odd to me that Microsoft would all of a sudden remove read-only access for anonymous users to the feedback system after years of allowing it and there being tens of thousands of links across many sites pointing to those tickets / items. 




1 Reply
best response confirmed by SolomonRutzky (New Contributor)

This issue has magically fixed itself, sometime in the past week or two.


(I will close this item, but am not deleting it as this was a valid issue for about a month that others most likely experienced).