Microsoft Secure Tech Accelerator
Apr 03 2024, 07:00 AM - 11:00 AM (PDT)
Microsoft Tech Community

Azure Information Protection , Windows 7 Enterprise SP1, Office 2010 Sp2 - protection does not work

Learn Expert

Hi all,


today I am testing, how to use AIP ( with Windows 7 Enterprise (all Updates, SP1) and Office 2010 (all Updates, SP2). 


In this connection I can´t protect (with Azure Vault Key), but I can label the documents. 



V1 = Internal with Label (check, worked)

V2 = secure with Label and Azure Vault Key (no, error)


Install with Admin rights. Local Admin rights on the Windows 7 Enterprise VM.


Solution & testing:

1. Give Adminrights to the Application; result: The application don´t open anymore.

2. new installation

3. reboot

4. change the lables




1: via right click

2: via Word


tested: Word, PowerPoint, Excel





Any ideas? Bug or Feature to Install Windows 10 :) 

4 Replies

Are you using Office Professional Plus 2010 and not some other version?

Office Professional Pro Plus  - single product, VLC


I found in the documentation, that I need Sp2. I made a double check and try to install the SP2 manually. The result of this:  "You don´t need any Updates. SP2 is installed". 


Word -> 14.0.7208.5000 (64bit)

I check the Reg Key, too and Reset the Settings. Everything = nothing. No secure only label

I found or didn´t find the issue. After two weeks and a switching of policies and labels it worked. I can reproduce the issue on other VMs and after 1 Week it works. Bu this time issue isn´t the right one for an enterprise company :) 

I will make a small research project about it. I happend only with Windows 7.