AIP UL Scanner - Does not Apply Auto-Labeling

Occasional Contributor

Hi all,

I have installed and configure the AIPScanner using UL, everything is runing great without errors, but the problems is that the scanner is detecting but not applying Auto-Labels with Sensitive Info Types like Keywords.

The Scanner detect the files on the files share, the same have some keywords and the scanner does not apply.


The policy of the scanner is set to enforce and the label was set in the Security & Compliance Portal.




File: Docx

Encryption: No

Labels: Created in Office 365 Security & Compliance

Label Policies: Created in Office 365 Security & Compliance

5 Replies
Please post screen shots of the Encryption options that you selected in your Label, and confirm that the AIP scanner service account has permission on the Label.
best response confirmed by Rubenreis (Occasional Contributor)

@Joe Stocker 


Hi Joe! Thanks for the reply.

I Solved this problem it was a minimal thing, beside the scan job policies to enforce (Print screen that i put before). There is other Policies enforcement in the repository this was set to off.



I Think the option "Content scan job default" is to make the Content scan job policies as primary.

Glad you got it fixed!

@Joe Stocker @Rubenreis 



I also get the same issue, AIP Scanner could discover but there is no file protected successfully,

I try to enforce the policy but the result still the same.



 if I tried to start-diagnostic the result showing no issue



we have automatic label policy with sensitive information type and it's working fine if I tried trough mail.

is there any missing configuration from AIP Scanner,

does anyone have suggest?


Thanks in advanced



Did you ever get to the bottom of this?
Our environment also has a simple AIP labeling Policy, the AIP scanner logs clearly show that Credit Card Data has been detected, the AIP scanner shows 'enforced' for auto labeling, but the AIP scanner never labels anything, not even setting the default label for all other data.


We even recreated everything twice from scratch - but still its not working.