AIP: An inactive label was specified, BadInputError.Code=General

Brass Contributor



We have created 4 new AIP labels and associated it with a new AIP Label Policy.

We are able to manually assign these new labels to Office documents.

The AIP Policy also successfully auto applies the "Company_General" label to all documents (via the AIP Scanner for on-prem files).

However, when the AIP Scanner tries to auto apply the label: 'Company_Confidential', to data containing Credit Card information, we get the following error:


"An inactive label was specified, BadInputError.Code=General, CorrelationId=5871dc03-XXXX-YYYY-8988-cf3e49da55e0, CorrelationId.Description=FileHandler, BadInputError.Code=General""",General,1fd3f303-XXXX-YYYY-a0c3-2ba85efc0f04,,,,Credit Card Number,,2022-03-29 01:43:50Z,,false,


However when I open this same file and press Save, the correct 'Company_Confidential' label is applied to the document.


What could be causing the AIP Scanner to fail like this?


Thank you,


2 Replies
as an update, I am also getting exactly the same error when I try to apply a "default label" to my documents via the AIP Scanner. I have triple checked the prerequisites, the AIP Scanner service account has all the required permissions. And I have worked through this document:

Then, in another case, the AIP Scanner detects the presence of 'Credit Card' information in the files (all the logs reflect that clearly). But when I modify the AIP 'Confidential' label to apply the 'Confidential' label to all files with with 'Credit Card' information present, the AIP Scanner does not do anything...I get the "Skipped due to - No match:2" entry in the log file.

Does the AIP Scanner still actually work, or is Microsoft deprecating that too?


PS. Yes, I have run the following successfully:

  • Start-AIPScannerDiagnostics -ResetConfig
  • Start-AIPScannerDiagnostics