Unable to activate some class teams

Occasional Contributor

Is anyone else experiencing an issue where Teams have been created using an uploaded csv through SDS, but some teachers are unable to activate the team and receive a message to try again later?

16 Replies



Yes me!! I've been trying for days now.  When you find a solution please update me!!

Hi @Matt6556 did you ever get a resolution for this one? I"m experiencing the same issue at our school and can't for the life of me work this out!



This is is the error we are getting




Yes that is exactly the error we are getting, not all classes but enough to be causing problems. it looks like the associated mailbox has not been created. If you try and view the mailbox it will say this is still being setup.

Hi @Matt6556 

By any chance after you syncronised with MS SDS, did you attempt to change any Team Names or Resync with new names but referencing the original email address for the Groups themselves?

@Kane_Ansell No we did not change any of the names.  I have tried to manualy create groups with the same name and run a SDS sync to add the users but all this will do is create a duplicate team with the users added.  The email address for the manualy created group is not the same as the SDS group but if you change it to match using powershell and then run a sync again you just end up with a duplicated group

HI Matt6556

Apparently the Microsoft Admin health is reporting SharePoint as experiencing Provisioning delays up to 96hrs. I think this might be our culprit.

@Matt6556 Removing all members from the Team > Activate Team > add members works for us. Maybe some members have issues. 


Any news about your issue?

I have the same problems and no idea anymore how to get is solved.

I have to activate 300 teams/classes.

Thanks for your thoughts and ideas!



@Schmiddi yes we now have all our Teams activated.  It appears to be a Microsoft Issue relating to a provisioning delay at their end.  We were applying the default policy packages to our users and for some this would fail to apply correctly.  We created a custom set of policy's and applied this to our users and then all the teams activated.  Microsoft are aware of the issue but last time we spoke with them they couldn't give a clear time frame for a resolution.

Hi @Matt6556

Can you provide me a little more details on the policies you created? What specific policies did you need to create?
Best Response confirmed by Deleted

@Kane_Ansell Originally we were applying the following policy packages to staff and students (Education secondary, education primary, education teacher). But these would fail so we ended up creating a Students Meeting policy, Students Live Events Policy, Students Messaging policy.  


These policy's have exactly the same settings a the default Microsoft provided ones except we have created these rather than using the default policys.


Hope that makes sense and helps.

@Matt6556 Hi,


how can I add a group (multible users) to that policy?

I have to add 700 students and 50 teachers.

Thanks for some more support

You have to add the policy to your users individually, I don’t think you can do it with a group. you can add the policy to the users with a power shell script. Adding it wasn’t a problem for us as we have a 3rd party integration that did this for us.

Did you guys find a resolution?

Hi @marcozo

Yes. We had raised a ticket with Microsoft and they had to delve into our tenancy directly to resolve it. Took them several days however for us it all started working properly again this morning.

Good luck with it all