SOLVED

Windows 11 Update (KB5009566) inhibits VPN connection

Occasional Contributor

Had a user contact me today, with a complaint that his VPN connection was no longer working. We are setup at the office with all Meraki equipment, and the limitations of the Client VPN on Meraki is well known; specifically VPN must be setup to only use PAP as the encryption. Meraki assures us that the passwords are always sent over an encrypted tunnel, and are never exposed in plaintext to the internet. 

 

For this user, when initiating the connection, this error presented immediately: "The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer." No amount of reconfiguration, rebuilding, or restarting fixed this issue, and it was only after the user reported a windows update that a rollback was performed which fixed the issue. Has anyone else had any issues with this update?

110 Replies

@cdodd5k I just applied the same update and have got the same symptoms, unable to connect to our network via built in windows VPN tunnel to our Meraki MX.

I experienced the same issue after installing KB5009566. Trying to connect to a Meraki VPN via L2TP/pre-shared key/PAP using the inbox VPN client resulted in the error message mentioned above. After uninstalling KB5009566 (reverting to 22000.376) I could connect successfully again.

Feedback Hub link: https://aka.ms/AAffr20
--
For me, this thread is displayed under "Microsoft Launcher" instead of "Windows 11". I'd suggest asking a moderator to move it to the correct space.
I also got the same issue immediately after applying that update today. Our office VPN also uses Meraki. I also tried several suggested fixes found online and none proved to be useful.

@cdodd5k 

 

After I applied the latest update from Microsoft I got the same error message. Tried multiple fixed but nothing worked.

Does your VPN use Meraki equipment?
Just confirmed that rolling back fixed the issue, so it definitely seems to be caused by the update.
We are using Meraki equipment.
I also rolled back the update and now the VPN is working again.
Avoid this update if you are using Meraki VPN.
I just reported the same thing. 2 laptops on Windows 11. Not using Meraki. Using Ubiquiti.
https://docs.microsoft.com/en-us/answers/questions/691993/can39t-connect-to-any-vpn-after-today39s-w...
same issue, can't connect to VPN on Ubiquiti. Native windows client, L2TP/IPsec with preshared key, MS-CHAP v2

Yup definitely same issue removing KB5009543 and restarting solves the issue with VPN...

 

Microsoft please help!

 

@cdodd5k 

Same here, Win11, KB5009566, Ubiquity VPN.

EventID: 20227, RasClient, CoId={​​​​​​​095D92EF-074F-0003-EDB4-5D094F07D801}​​​​​​​: The user XXX dialed a connection named HAVIT VPN which has failed. The error code returned on failure is 789.

@cdodd5k 

 

Hello ! Same here after updated to KB5009566.

 

Same here this morning. Rebooted for updates, went to connect to my office and boom can't connect. Removed KB5009566 and rebooted - connected fine. Thanks for raising this :)
I have same error with Native windows client, L2TP/IPsec with preshared key

@stelis101 

How do you roll back the update?

 

This issue also exists for Mikrotik based L2TP VPNs Windows 10 and Windows 11 after the cumulative update on January 11, 2022.

Control Panel > Programs and Features > Click View Installed Updates in the top left of the sidebar > Scroll down to the Microsoft Windows section > Find the KB number > Click Uninstall > Reboot when done.
Same issue on Win10...uninstalled 2 updates from 11.1. -> FIXED. Not sure which of those two updates make this trouble.