[ERROR] Windows Security Center Empty (cannot open security center via setting)

%3CLINGO-SUB%20id%3D%22lingo-sub-2831331%22%20slang%3D%22en-US%22%3E%5BERROR%5D%20Windows%20Security%20Center%20Empty%20(cannot%20open%20security%20center%20via%20setting)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2831331%22%20slang%3D%22en-US%22%3E%3CP%3EWindows%20Security%20Center%20Empty%20(cannot%20open%20security%20center%20via%20setting).%3CBR%20%2F%3E%3CBR%20%2F%3EI%20just%20upgraded%20Win%2011%20today%2C%20and%20i%20realized%20i%20cannot%20open%20defender%20or%20windows%20security%20(via%20straight%20windows%20security%20center%20or%20via%20setting%26gt%3Bprivacy%20and%20security).%20All%20services%20just%20running%20smoothly%20(windows%20security%2C%20etc).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EWindows%20Version%3C%2FSTRONG%3E%3C%2FP%3E%3CUL%3E%3CLI%3EEdition%20Windows%2011%20Pro%3CBR%20%2F%3EVersion%2021H2%3CBR%20%2F%3EInstalled%20on%20%E2%80%8E10%2F%E2%80%8E10%2F%E2%80%8E2021%3CBR%20%2F%3EOS%20build%2022000.194%3CBR%20%2F%3EExperience%20Windows%20Feature%20Experience%20Pack%201000.22000.194.0%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%3CSTRONG%3EDefinition%20Version%20(via%20cmd)%3C%2FSTRONG%3E%3C%2FP%3E%3CUL%3E%3CLI%3EService%20Version%3A%204.18.2109.6%3CBR%20%2F%3EEngine%20Version%3A%201.1.18600.4%3CBR%20%2F%3EAntiSpyware%20Signature%20Version%3A%201.351.148.0%3CBR%20%2F%3EAntiVirus%20Signature%20Version%3A%201.351.148.0%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%3CSTRONG%3EWhat%20expected%20behaviour%3F%3C%2FSTRONG%3E%3C%2FP%3E%3CUL%3E%3CLI%3EOpen%20defender%20via%20setting%20or%20windows%20security%20is%20success.%3C%2FLI%3E%3CLI%3ECan%20manage%20protection%20on%20windows%20security.%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%3CSTRONG%3EWhat%20I%20did%20to%20solve%3F%3C%2FSTRONG%3E%3C%2FP%3E%3CUL%3E%3CLI%3ERun%20reset%20windows%20security%20via%20app%20setting.%3C%2FLI%3E%3CLI%3ERun%20troubleshoter.%3C%2FLI%3E%3CLI%3ERestart%20all%20the%20services%20and%20dependencies.%3C%2FLI%3E%3CLI%3EChecking%20for%20update%20via%20windows%20update.%3C%2FLI%3E%3CLI%3ERunning%20Get-AppxPackage%20Microsoft.SecHealthUI%20-AllUsers%20%7C%20Reset-AppxPackage.%3C%2FLI%3E%3CLI%3ERunning%20DISM%20and%20SFC.%3C%2FLI%3E%3CLI%3EUninstall%20third-party%20security%20software%20(Smadav%20Antivirus).%3C%2FLI%3E%3CLI%3EEdit%20Policy%20Group.%3C%2FLI%3E%3C%2FUL%3E%3CP%3EThe%20problem%20still%20exsist.%20The%20Windows%20security%20only%20show%20nothing%20on%20the%20page.%20Everytime%20i%20open%20Windows%20security%20via%20setting%26gt%3Bprivacy%20and%20security%20i%20got%20setting%20freeze%20cannot%20doing%20anything%20but%20closing%20it.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22fndrsm_0-1633873914275.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F316389iB41F4FC3A99B7F84%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22fndrsm_0-1633873914275.png%22%20alt%3D%22fndrsm_0-1633873914275.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22fndrsm_1-1633874033540.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F316390iC4348B53B9E4BBAE%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22fndrsm_1-1633874033540.png%22%20alt%3D%22fndrsm_1-1633874033540.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22fndrsm_2-1633874042014.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F316391i92896C6D53C57DAE%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22fndrsm_2-1633874042014.png%22%20alt%3D%22fndrsm_2-1633874042014.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2831331%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%2011%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2846048%22%20slang%3D%22en-US%22%3ERe%3A%20%5BERROR%5D%20Windows%20Security%20Center%20Empty%20(cannot%20open%20security%20center%20via%20setting)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2846048%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1181159%22%20target%3D%22_blank%22%3E%40fndrsm%3C%2FA%3E%26nbsp%3Bsame%20problem.%20mine%20was%20that%20when%20you%20click%20the%20security%20center%2C%20nothing%20happens...if%20you%20right%20click%20the%20shield%20icon%20on%20the%20taskbar%2C%20you%20get%20the%20image%20below.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2846636%22%20slang%3D%22en-US%22%3ERe%3A%20%5BERROR%5D%20Windows%20Security%20Center%20Empty%20(cannot%20open%20security%20center%20via%20setting)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2846636%22%20slang%3D%22en-US%22%3ESome%20people%20get%20this%20fix%20on%20previous%20beta%20in%20couple%20months%20ago.%20They%20running%20step%20number%205%20which%20i%20mentioned%20on%20what%20i%20did%20to%20resolve.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2846687%22%20slang%3D%22en-US%22%3ERe%3A%20%5BERROR%5D%20Windows%20Security%20Center%20Empty%20(cannot%20open%20security%20center%20via%20setting)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2846687%22%20slang%3D%22en-US%22%3EI%20tried%20that%20but%20didn't%20work....also%2C%20if%20i%20remembered%20it%20right%2C%20that%20fix%20works%20only%20for%20windows%2010%3F%3C%2FLINGO-BODY%3E
Occasional Contributor

Windows Security Center Empty (cannot open security center via setting).

I just upgraded Win 11 today, and i realized i cannot open defender or windows security (via straight windows security center or via setting>privacy and security). All services just running smoothly (windows security, etc).

 

Windows Version

  • Edition Windows 11 Pro
    Version 21H2
    Installed on ‎10/‎10/‎2021
    OS build 22000.194
    Experience Windows Feature Experience Pack 1000.22000.194.0

Definition Version (via cmd)

  • Service Version: 4.18.2109.6
    Engine Version: 1.1.18600.4
    AntiSpyware Signature Version: 1.351.148.0
    AntiVirus Signature Version: 1.351.148.0

What expected behaviour?

  • Open defender via setting or windows security is success.
  • Can manage protection on windows security.

What I did to solve?

  • Run reset windows security via app setting.
  • Run troubleshoter.
  • Restart all the services and dependencies.
  • Checking for update via windows update.
  • Running Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage.
  • Running DISM and SFC.
  • Uninstall third-party security software (Smadav Antivirus).
  • Edit Policy Group.

The problem still exsist. The Windows security only show nothing on the page. Everytime i open Windows security via setting>privacy and security i got setting freeze cannot doing anything but closing it.

fndrsm_0-1633873914275.png

fndrsm_1-1633874033540.pngfndrsm_2-1633874042014.png

 

 

 

 

10 Replies

@fndrsm same problem. mine was that when you click the security center, nothing happens...if you right click the shield icon on the taskbar, you get the image below.

Some people get this fix on previous beta in couple months ago. They running step number 5 which i mentioned on what i did to resolve.
I tried that but didn't work....also, if i remembered it right, that fix works only for windows 10?
No, there are two command, which one for win10 and i mentioned above is for win11. Well i dont know why that is not work. Really, Microsoft Team tells me via live chat that my computer no eligible and unsupported hardware, but for many components in windows, why windows defender as the victim :face_with_tears_of_joy:
Mine supports all requirements but i still have the same problem with the security center:>...the support personnel clearly don't know what they are talking about lol
Hi, this worked for me:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

just use the same powershell in admin mode and enter the command and wait for it to be finished. the security center worked again
I've done it before, but i did not remember the full command, i just remember the last "manifest.xml". I dont know its the same command or not. I try to running the command u suggest. but it shows almost all red output

" Deployment failed with HRESULT: 0x80073D02, The package could not be installed because resources it modifies are currently in use."
"Cannot find path 'C:\AppXManifest.xml' because it does not exist."
Check your security center....mine had that red outputs but it actually fixed the problem
I did, but still showing nothing. I dont know, i already using mcafee