Battery stuck at 0% after Windows 11 upgrade

Frequent Visitor

Yesterday I upgraded my laptop (Lenovo Yoga S730-13IWL) from Windows 10 to Windows 11, using the "Windows 11 Installation Assistant" as it wasn't offered to me automatically yet. While it was updating it was plugged into power, and when I shut it down it reported having a 100% charge on the battery. When I opened it again this morning however, it almost immediately reported 0% and shut down. I am still able to turn it back on while it's plugged in, but the battery doesn't appear to charge at all, and as soon as i unplug it it shuts down.


I of course have no idea whether this is a problem with the software or the battery actually just went bad, but the coinciding timing makes me believe that it is at least in some way connected to the upgrade.


Interestingly enough, the "battery levels" under Windows' power settings reports the percentage to be at 100%: 

Battery levels.png


Lenovo Vantage just reports that the battery is extremely degraded:

Vantage battery details.png


I have tried reinstalling the "Microsoft ACPI-Compliant Control Method Battery" driver but to no avail.

2 Replies

Your laptop battery is all right, it is acpi compliant control method battery issue!

Just disable acpi compliant control method battery under battery in Device Manager and see if it works for it worked for me...though have not upgraded yet but faced same issue with new windows update of October 2021 and it almost made me to order new battery pack and desktop, which ultimately me did not. @HolleBolle 

though don't know why it started right after regular updates, but will keep it disabled for a while. The system now is kept plugged in to the power source.

@HolleBolle  Hi I have the exact same issue as you after updating to windows11 from 10, but my laptop is a acer sf-314-59 with 11th gen intel i5 also I updated mine through the prompt in windows updates, not through the "windows 11 installation assistant".