Age of Empires Crashing after Update

New Contributor

I use Parallels on a Mac, I paid hundreds of dollars for the subscription and Microsoft software for the exclusive reason to play this game after much research which stated that you can play the game fine on parallels with no issues. I have been happily playing Age of Empires Definitive Edition II for weeks now with absolutely no issue until the other day when it updated, now it will allow me into the game, it will allow me to start a new game and as soon as i click anything within the started game, the whole game crashes. I've restarted the computer, I've uninstalled the game and reinstalled it, nothing works, something is going on after that update. If i can't play the game I've wasted my money. Help please, can I get my money back if it can't be resolved?.

6 Replies
Hi,
Xbox/Microsoft game Refunds: https://support.xbox.com/en-US/help/subscriptions-billing/buy-games-apps/refund-orders

I can't possibly say why it doesn't work on a Mac with parallels but it works fine on Windows 10.
maybe try running Windows 10 with bootcamp on Mac?

Same thing happened to me! Does anybody know how to uninstall the latest update?

you can't uninstall game updates.
is your OS up to date?

I have exactly the same problem as you do. I've read that some users of windows also have this problem but the solutions does not apply for parallels. I guess we should wait for an update or a new patch...

@spidey_d 

@edfranco336my husband managed to fix it. What he did was; if you are using parallels like me, you need to go into the control centre (right click on your parallels icon and select control centre). Then you click the little setting icon in the control centre to open settings.

 

The main problem is the processor settings but there were 3 settings he changed that fixed the problem.

1. make sure under settings in the hardware tab, you've got 4 processors selected.

2. make sure in the same section that the memory is at the max it can go.

 

I'm pretty sure this would be enough to fix the issue on its own however he did make one other change and that was in the general tab where he made 'configure for:' changed this to 'Games only' which is for full screen 3D games with high demand for resources.

 

Hope this helps.

 

H.

@JIGB89I put how I fixed it below in someone else's comment! Hope it works for you too.