This project contains links to one or more data sources

Copper Contributor

Every time I open this project I get this message. have tried everything google suggested, but it isn't a common issue with project, but it is on excel. Additionally, the project is about twice the size of my other projects. It isnt connected to any other projects nor are there any external successors. Thanks in advance.

16 Replies
best response confirmed by Dale Howard (MVP)


Apparently at some point you or someone else created imbedded links to the Project file. It could have been a hyperlink, the file was part of a master/subproject structure, a resource pool/sharer structure, or had cross-project links to another file, or perhaps had an imbedded image. Lots of possibilities.


Also, the fact that your file is also much larger than your other similar files indicates there may be corruption. I suggest you try each of the methods in the following Wiki article. 


I have experienced the same issue when opening MS project files (.mpp) that were last saved in 2014, that have no links.  I rarely use any links and experienced this with many different files over several years.   One of the files I deleted all tasks, saved and when I re-opend it, I got the same message.  I'm wondering if it is something within MS Project.  


Any thoughts?


I never experienced that issue and I've been using Project for over 20 years, many versions. Did you look at the Wiki article I suggested?


For reference, what version of Project are you using?



I reviewed the article, but the only step I did was to immediately save the file after opening. I have a lot of formatting, so I'm reluctant to lose that. I opened several files over the past 10 years and the earliest that produced the message was in 2014. Files from 2011 did not show the message. All of my files are fairly small (300 tasks or less) and I'm the only one editing them, so I know which ones have a link. This seems to have just started for me. I have links from WORD "to" MS Project that has been working fine, but now when I open the WORD document, MS Project also opens with that popup and both are files held until I respond to the popup. This is happening with too many files to be a file issue.

I'm using Online Desktop Client MSO Version 2111 Build 16.0.14701.20206 64 bit (Click-to-Run) which was installed from O365.

As an FYI, I tried method 2 and I no longer have the popup about the link(s).   I lost quite all the formatting as was mentioned and I had some graphical representations of some numbered fields that I had to redo.  All in all, it didn't take too long.  So, the file for this project seems to be working.   Thanks for the push to try one of the methods.



You're welcome and thanks for the feedback. If I answered your question please consider marking my response as the answer.
I had the same problem and tried the Technet Method 2. Not only did it fix the error message, but my file size went from 18Mb to 8Mb. It was also opening and saving and searching a lot faster. I definitely had file bloat. Thanks @jamesbl390 !


I recently received a new computer, I am on Office (project) 365.
I started getting the pop up only when I got my new computer. 
This problem occurs EVERY TIME I open ANY PROJECT file. My colleague opens the same files without the warning.... Hence, it should be PC / software setup not a problem with the project file.

This is an older post so it's not totally clear exactly what "this problem" is in your case. I suggest you re-post as a new question and fully explain the issue.






When a task in current project A has External link to a project B, which some how does not exist in the same location or file name changed, your project will show the error every time you open it.

3 ways to find and remove them as below.


  1. Choose View > Gantt Chart.

  2. If any filters are turned on, turn them off: On the View tab, in the Data group, select No Filter in the Filter list.

    When AutoFilters are turned on, an arrow is displayed to the right of each field heading. Turning off AutoFilters displays all tasks.

  3. Choose Project > Links Between Projects.

  4. OR easy way to find insert a column, External task and look for YES in it  and then break the dependencies.

  5. Also you can find external tasks by finding C:\Users ..... in Predecessor or Successors column then delete it
Hi John

Every time I open an MS P file, I get the following error. This does not happen when my colleague tries to open the same files:

"This project contain slinks to one or more data sources that may be unsafe or have been disabled ...."
That's not much information to go on.
1. Where are the files stored?
2. Do the files have any hyperlinks?
3. Do the files have external predecessors/successors?
4. Are the files part of a linked structure (i.e. master/subproject or resource pool/sharer file)?
5. What version of Project do you have and what version does your colleague have?
6. Did you try the methods listed in the Wiki article I mentioned in my original response on this thread?
search C:\users in predecessor or successor columns and delete them.
It should be resolved.


I just saw the release notes for the March 30 update (current channel) and it mentions a fix for this issue. The March 30 release is:

Version 2203 (Build 15028.20160 CTR).




In MS Project a vast majority of obscure problems can be generated with very hard to find sources of a standardized solution.  In my experience, formatting is a significant cause to these problems, from simple to complex formatting.  Also, using and standardizing the Views, Tables, Filters and Custom fields and ANY Macros added into a MS Project file can lead to easy work, but can generate these kinds of errors.  

I experienced the same thing the original post raised a few years ago and resolved it by doing the following:

1) Save your file with the error message as any other copy version name, e.g. myfile_r1.

2) Before closing your MS Project file, review if your formatting factors such as views, tables, filters, custom fields and Macros are accounted for in the MS Project file - Info - Organizer.  They should be there already unless you customized your installation and turned that feature off.

2a) MS Project by default has two Organizer views the left panel is the installation installed organizer features, the right side is the file organizer features, they DO NOT have to be identical.  The left, installation version allows you to replicate your "tools" to other MS Project files, but can also load garbage or corrupt tools, so work them to be clean.

3) This step isn't necessary but its cleaner.  Close the MS Project file you just saved as "x_r?".

4) Open the file you just closed and go directly into the File-> Info -> Organizer set.

5) Remove ALL formatting associated to the file in question, this will be the box on the right of the organizer window.  Walk across all tabs and remove everything you can from the file.

5a) If you change the default view in your project file to the default GANTT view then you can delete all of  your customizations.

6) Save the file as either the same name "x_r1" or as a new version, e.g. "x_r2".

7) Close the file and then re-open it.

The error or the error messages regarding "add-in" function should stop, meaning you removed the cause.

8) In the new version of the same file with no formatting, simply go back into the Organizer and reload your saved formatting.  You can do this one by one and see which one is the culprit, or you can simply reload all and see if you've solved the problem.


Note: formatting of all kinds bares risk, but also bares considerable fruit, use it at your discretion.


Please also check OLE objects, which can add automatically when you copy paste from other ms office app.

When you save to mpt format you can remove them after you selected all options. (baseline, actual, resource cost..etc click save and you will have a question)