SOLVED

PWA 2013 Runtime Error

%3CLINGO-SUB%20id%3D%22lingo-sub-2662325%22%20slang%3D%22en-US%22%3EPWA%202013%20Runtime%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2662325%22%20slang%3D%22en-US%22%3EIis%20it%20normal%20for%20PWA%202013%20to%20fall%20asleep%20at%20night%3F%20We%20get%20a%20Runtime%20Error%20each%20morning.%20Whoever%20is%20first%20to%20open%20the%20page%20gets%20the%20error%20each%20morning%2C%20then%20its%20fine%20the%20rest%20of%20the%20day.%20Is%20this%20normal%3F%20If%20so%2C%20is%20there%20a%20solution%3F%20Do%20we%20need%20to%20edit%20the%20web.config%20file%20or%20is%20a%20daily%20wake-up%20script%20needed%3F%20Thanks%20in%20advance%20for%20any%20help%20with%20this!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2664108%22%20slang%3D%22en-US%22%3ERe%3A%20PWA%202013%20Runtime%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2664108%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1131687%22%20target%3D%22_blank%22%3E%40david20b%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIt%20is%20normal%20for%20the%20first%20user%20to%20hit%20the%20SharePoint%20%2F%20PWA%20site%20to%20have%20a%20slow%20load%20time%20due%20to%20IIS%20recycling%20then%20the%20.net%20app%20recaching%20etc.%20-%20the%20runtime%20error%20is%20not%20normal%20but%20must%20be%20related%20to%20the%20slow%20start%20up.%20Look%20at%20using%20a%20warm%20up%20script%20such%20as%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2Fspjeff%2Fspbestwarmup%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2Fspjeff%2Fspbestwarmup%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPaul%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor
Iis it normal for PWA 2013 to fall asleep at night? We get a Runtime Error each morning. Whoever is first to open the page gets the error each morning, then its fine the rest of the day. Is this normal? If so, is there a solution? Do we need to edit the web.config file or is a daily wake-up script needed? Thanks in advance for any help with this!
1 Reply
best response confirmed by david20b (Occasional Visitor)
Solution

Hello @david20b 

It is normal for the first user to hit the SharePoint / PWA site to have a slow load time due to IIS recycling then the .net app recaching etc. - the runtime error is not normal but must be related to the slow start up. Look at using a warm up script such as https://github.com/spjeff/spbestwarmup 

Paul