Project Web App and Power BI Integration

Occasional Contributor

Hi, 

 

I'm trying to connect my data from Project Web App iunto Power BI but the error message, "Failed to update data source credentials: The credentials provided for the OData source are invalid."

 

I have copied and pasted the PWA site link direct from the site so there are no typos in the site name and have tried to connect anonymously and with basic credentials (using my site login). 

failed to connect.JPG

Additional info that may be useful:

I have a Project Professional 3 license with admin permissions, along with a Power BI Pro license (60 day free trial). 

 

 

7 Replies

Hello @BlissL ,

You will need to select the Organizational account option.

Paul

Hi @Paul Mather ,

Sorry I should've clarified - I've tried to connect data using all the options, including the organizational account and it still can't authenticate:

organizational accountr.JPG

 

UPDATE:

I've managed to connect the data for the Power BI web site through using the Project Web App PBI template, but only as it had the option under the organisational account to use OAuth. However I can't find this option on the Desktop app - when I'm signed into my normal account using the Organizational Account it still can't authenticate my credentials. 

Hello @BlissL ,

The Organizational account is correct but it looks like you are using the incorrect PWA URL as you have /default.aspx on the end? Enter the PWA Site Url without the /default.aspx for example:

https://tenant.sharepoint.com/sites/pwa 

Paul

@Paul Mather 

Unfortunately still doesn't like to authenticate with the 'right' URL without the /default.aspx at the end.

org account c1.JPG

Tried all levels to apply the settings to and no authentication

  • tenant.sharepoint.com/
  • tenant.sharepoint.com/sites
  • tenant.sharepoint.com/sites/pwa

Hi @BlissL ,

Does the account you're using having access to query the report API? In a web browser if you go to {pwaSite}/_api/ProjectData, for example https://tenant.sharepoint.com/sites/pwa/_api/ProjectData does you see the collections listed?

Paul

@Paul Mather 

Yes, it looks like it Collections api site.JPG

There is no reason on the Project Online side why this wont work then @BlissL , there must be an issue on your Power BI desktop client. Can another user try on their Power BI Desktop client or you try another device if possible? This will help with next steps.

Paul